Stability under Linux: Quad

After vanilla install, several crashes occurred. First I changed savetime to 5 (!) At some point apport showed up and I noticed a segmentation fault related to the Quad. So I turned that off, together with tooltips.

This was a few weeks ago and since then, everything is rock stable. Although I've lost apport information, it is probably saved in /var/crash, I thought it might be a good idea to share this information.

(System: AMD, Xubuntu 19.04, BricsCAD v19)


  • So you don't use the Quad? I like that feature, but I would give it up if it meant I wasn't crashing so much. I just need to figure out how to turn these things off.

    Thanks for the hint,

  • @Wiebe van der Worp said:

    (System: AMD, Xubuntu 19.04, BricsCAD v19)

    So Bricscad is also running fine on XCFE ?

  • I just spent the whole afternoon restarting my BricsCAD or waiting for it to come out of a hang quitting, rinse, repeat. I was very excited to have a few good hours this morning on my new linux work station. But now, sometimes my files only stay open for a few seconds. The 3D BIM model is more stable than my sheets. But, everything is having crashes and hangs in v19 (and v20 as I was excited to try it with the new release.) Is it possible to have such bad settings or file parameters that it becomes unworkable?

    Audit is not finding issues.

    I think turning off Quad helps, but that is such a key part of workflow for me it's hard. I turn off tool tips, but how do I make that a default setting?

    (System: Intel, with AMD graphics, Pop_OS 19.10)

  • I have to add: Wiebe, you saved my goose today. I have worked since my last comment without crashing. Bricsys can work on a specific bug instead of a ranting crying me.

  • Glad it helped minimalix. In Stockholm I had a discussion about this with Torsten Moses and he pointed out the problem was a bit deeper rooted. I can't remember the details, maybe he can elaborate on it. However, it is a pity to understand it persists in v20 too. It needs attention from developers. I thought there was a support request about this, not 100% sure.

  • Hm, we have never been forced to disable the quad in order to make BricsCAD run well.

    Maybe you should try some of these settings..

    1. Make sure you are using a compositor on your system. If you are on Gnome or Plasma, that should be taken care of by the DE by default.
    2. Make sure you are not using Wayland, but use Xorg.
    3. Depending on your hardware and your version of BricsCAD, try some of the following:
    • In v19 and earlier versions to avoid push-pull crashes; Edit '~/.bricscad/config' and set 'DRAGMODEINTERRUPT=0' and set ''CROSSHAIRDRAWMODE=0'.

    • In v20 it seems to be fine using the default values of 'DRAGMODEINTERRUPT=1' and 'CROSSHAIRDRAWMODE=3' in '~/.bricscad/config'.

    • In v19 and earlier versions we used 'GLSWAPMODE=2' or 'GLSWAPMODE=3' in '~/.bricscad/config' with the open source AMD drivers, depending on the GPU generation present on the system.

    • In v20 (when 'CROSSHAIRDRAWMODE=3') it seems like 'GLSWAPMODE=2' in '~/.bricscad/config' works well for all versions of the open source AMD driver.

  • At this point, I can confirm that v20 is stable in an out of the box installation environment, with and without compositor, with QUAD enabled, AMD community drivers. CROSSHAIRDRAWMODE 3 seems okay, though I have not tried it with some 3D-constraints, causing cursor duplication during command input in v19.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!