Saving and autosaves take toooooo looooong!

Also loading small lisp routines the first time in a drawing.  It just takes so long that my architect is getting angry with me.  It even affects the autosaves in the drawings when he opens the drawings in AutoCAD.  This is unacceptable and it's going to cost me my client!  Or it might cost me full price for AutoCAD because my subscription is about to expire.

Bill DeShawn

Comments

  • I only use 2d and the files generally under 4Mb, but virtually every operation is instant for me in V15.
    Hard to guess what might be wrong, but going slow is not normal.
    Why not submit a support request with your file.

  • Bill,

    Try running the Task Manager whenever you see an unexplained slowing of seemingly normal tasks. Perhaps there is some rogue application or process trying to eat up CPU time. Run the AUDIT & PURGE commands, check your anti-virus and disk manager tools - these are few things I would investigate.

    Good luck!

    Rakesh Rao
    Smarter .dwg CAD



  • Is this computer part of a domain?
    so computer connected to the server?

    Use at least a 1gbps connection.
    it's very easy to occupy a 100mbps connection , even in 2D architectural work.

    describe you computer, so:
    1) processor type
    2) How many ram installed
    3) Which video card is used.
    4) windows version.
    5) all drivers up to date


  • Also keep in mind, always purge and audit dwg's before last save.

  • There are certainly many possible causes.  Do other computers have the same issue saving the same drawings?

    Of course, it could be that your drawings are more complex than what your computer can handle, especially if the computer is very old.

    There is a company who sends me poorly managed drawings occasionally..  My normal practice when I receive a drawing from them, is first to delete all the stuff they have off to the side, that does not show in any views.  This seems to be "working space"  for various elements of the design.  Then, there are also many blocks that are not used, that probably came in when they inserted things from their block library.  Finally, I purge the drawing, and normally obtain a 5x to 10x reduction in file size.

    -Joe
  • Assuming you don't have a great deal of unnecessary objects in the drawing, there are some settings you can change, which will improve saving a bit when doing autosaves.

    ISAVEBAK

    Incremental save backup

    Controls the creation of a backup file (BAK). Improves the speed of incremental saves if switched off, especially for large drawings.

    Please notice that in some cases (i.e. a power failure during a save), it might be possible drawing data are lost.

    ISAVEPERCENT

    Save percent

    This system variable controls how often BricsCAD performs a full save. A full save reorganizes all the data in the drawing database and creates a compact file. A partial save stores all changes a the end of the drawing data base. A full save takes longer to be executed than a partial save. If ISAVEPERCENT = 0, each save is a full save. The higher the value of ISAVEPERCENT, the longer the time between two full saves.


    -Joe
  • I would be interested in an update from the OP.
  • Thank you for your thoughtful reply.  And to all those who are reading this reply who also responded.  I have done most, and possibly all the suggestions that are out here.  Probably the one thing that I did that helped was to increase my SAVETIME from 5 to 15.  I think that because our drawings are on DROPBOX, and I'm on a DSL modem from home, that this could be part of our problem.  However, the architect with whom I work is on XFINITY, and has a much faster service than I do.  And he, too experiences long AUTOSAVE times from my drawings.  However, his AUTOSAVE was every one minute.  I asked him to change it to 15.  I haven't heard any complaints since, and hopefully for him it's no longer an issue.  This makes sense to me, because if it takes two minutes to do an AUTOSAVE, and your CAD program is trying to do an AUTOSAVE every minute, you can probably crash your computer.  Anyway, although things aren't ideal yet, they are getting better.  Thank you all for your help.

    Bill DeShawn

  • While using Dropbox directly is certainly your main issue,  I think the autosave is to a local directory, unless you changed it.  It saves to a file with the FILENAME.SV$  as the name, in a specific directory that is not where the file resides.  So, using dropbox would not affect the autosave speed.

    -Joe
  • What you say about the autosave file location makes sense. Nothing else seems so be slowing things down except saves and autosaves.  Isavepercent was something I never quite understood how I could benefit from it. Kinda like partialopen. 
    Bill DeShawn
  • quote]

    Bill,
    Rakesh
    I frequently run Ccleaner and Malwarebytes to rid my computers of rogue apps. Thanks.
    Bill

    Try running the Task Manager whenever you see an unexplained slowing of seemingly normal tasks. Perhaps there is some rogue application or process trying to eat up CPU time. Run the AUDIT & PURGE commands, check your anti-virus and disk manager tools - these are few things I would investigate.

    Good luck!

    Rakesh Rao
    Smarter .dwg CAD



  • There can be peculiarities in the drawing data that slow down the program, for instance some behind-the-screen-dictionaries may be unexpectedly massive without them having any benefit.  I think it would be helpful if you just enter a supportrequest so that the case can be analyzed, rather than trying out general performance improvement strategies. It is not a slow program.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!