units

Elementary - just received an old dwg, set to report distance in m. How do I make it report in mm? tried every setting I can think of, done a RE.

Comments

  • Edit the LENGTHUNITS system variable in the SETTINGS dialog box and remove all but the mm unit.

  • I've edited all of those, length, area, vol, even mass! and DI still returns metres, both in dynamic dimension box and command bar. It's Acad version R27 (2013) but created 2007.

  • Hi Tom, send in a support request then and add the drawing.

  • Thanks - done that.
    Multiple units were selected in Settings - m as well as mm as well as various imperials - until I reduced that to mm only. Maybe in Settings>Property units, Acad 'automatically formatted when INSUNITS not zero' as m, and someone mentally divided all desired dimensions by 1000.

  • There are 2 things.
    INSUNITS and LENGTHUNITS

    LENGTHUNITS are just for displaying.
    If INSUNITS are wrong and you would need to change, you would also
    have to scale the whole file.

    LENGTHUNITS are misleading too.
    1.
    Display Units changing all the time in DYNDIMs making me crazy too.
    Therefore you have to delete all unwanted units from (each) File
    to only have the one that you want to see.
    2.
    So an INSUNIT millimeter File can display LENGTHUNITS in meter in DYNDIMS
    that way, if you wish, but when you enter Number Fields it will use input
    in INSUNITS though !
    So you would either need to explicitly enter also the Units in number field
    for each entry or switch your units thinking back to millimeter for input.

    As adapting INSUNITS to your need isn't that easy,
    (You can't even know or see them that easy, that is why I always go to
    File Settings INSUNITS first, when I open any foreign Files)
    I miss an additional WORKINGUNITS setting, that lets me work in my preferred
    Units of choice, for unit display and input.

    And of course, make Bricscad accept German Keyboards NumBlocks Komma,
    as a valid Decimal Separator.
    (By making Bricscad just reading the key **Num+, ** as a point.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!