Custom Layer LISP routine - screen interrupted error *SOLVED*

Hello,
New to BricsCAD and the forum.
Looking for some help for a screen interrupted an error occurred while rendering entity.
I installed BrisCAD Lite on my home PC with version V21 to test before purchasing at my workplace. (We are still using AutoCAD 2012). All works fine at home no errors and I used it for almost a full year. I installed V22 at the office and all worked well for about six months as a trial before purchasing. We then purchased 22 seats and I started installing on several machines. This is when the issues started. Since it has been installed on several machines we are getting these screen interrupted errors. All machines are running Windows 10 and have the latest graphics card drivers. Some machines are referencing the server for support files and some are all local as a test to see if the server may be the issue. It does not seem to matter either way.
If anyone has run into this error or there is something not compatible with the LISP routine and BricsCAD, any help would be much appreciated.
I am attaching the error message along with the LISP routine.

Thank you in advance for any help.

Dru

Here is the LISP routine. It is one of many commands for switching layers. They are all the same format.

(defun C:SW1()(COMMAND ".-LAYER" "u" "*" "T" "P-1-SW" "S" "P-1-SW" "")(MCHECK)
(COMMAND ".-layer" "F" "*" "T" "0,DEFPOINTS,*TITLE,*1-FLOOR-PLAN,*1-ELEMENT,*1-TEXT,*REF POINT,*P-1-SW,*P-1-WALLSET,*S-ELEV,*S-SEC,*S-SEC-TEXT,*P-STAIRS-DIMS,*P-STAIRS-KICKPLATE,*P-STAIRS-RAILING,*P-STAIRS-RISER,*P-STAIRS-STRINGER,*P-STAIRS-TREAD,*P-STAIRS-PLATFORM"
"lo" "1-FLOOR-PLAN,1-ELEMENT,1-TEXT,P-1-WALLSET" "")(princ))

Comments

  • Hello,

    2 ideas :
    first of all, check your opened dwg file(s) with
    _audit _yes
    this fixes dwg database errors, which are the major reasons for "screen update interrupted"

    If the same error happens with audited/fixed dwg files, please check MTFLAGS and set as 0 :
    MTFLAGS=0
    in commandline
    then restart BricsCAD (multithreading settings have affect in next session only)

    hope this will help ?
    many greetings !
  • dstarook
    edited September 1
    Torsten,

    Thank you for the reply.
    I have tried the audit command and still get the errors. I will try the MTFLAGS and update.

    UPDATE: The MTFLAGS=0 seems to have solved the issue. It has been 3 weeks since we tired this setting and no errors. Thanks to all for the help and to Torsten for the solution that worked in our case.
  • You can drill down and find these problem entities using the STRUCTUREPANEL using the given entity handle name. This is the bit of code at the end of the error message


    In the Structure Panel you can search on a handle name


    This will filter to the related entity. If you right click on it you can zoom to it's location on the drawing to get a better idea of what it is.


    In some cases you can edit the properties of the object from the property panel to fix it, or if its not important, simply delete it from the drawing.


    Regards,
    Jason Bourhill
    BricsCAD V22 Ultimate
    CAD Concepts


  • It looks like it may stop at (MCHECK) where is code for this defun.
  • @ALANH
    Here is the MCHECK defun
    ;check to see if user is on 'Model' tab
    (defun MCHECK(/ KW)
    (if (/= (getvar "CTAB") "Model")
    (progn
    (initget "y Y N n")
    (setq KW (getkword "\nSwitch to 'Model' tab? [Y, N]: "))
    (if (= nil KW)(setq KW "Y"))
    (if (= (strcase KW) "Y")
    (setvar "CTAB" "Model")
    (exit))
    );\progn
    );\if
    )
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!