Selection Artifacts

Hi everyone. I would like to know if there is a way to prevent selection artifacts appearing when selecting section planes. See attached image for what the problem looks like. I am currently evaluating BricsCAD as a potential replacement for Revit. I have noticed this weird effect using the current AMD Adrenaline driver on my AMD Radeon Rx 6800. The 22Q2 Pro driver doesn't do it, but the 22Q3 Pro driver does. Does anyone know any settings that might help? I could go back to the Pro 22Q2 driver, but then I miss out on recent performance enhancements in the current driver.

Comments

  • DWills said:

    I have noticed this weird effect using the current AMD Adrenaline driver on my AMD Radeon Rx 6800. The 22Q2 Pro driver doesn't do it, but the 22Q3 Pro driver does.src="https://forum.bricsys.com/uploads/editor/8a/sywovtdgjg68.jpg" alt="" />

    Thanks for testing.

    I have the same GPU and so I can avoid the 22Q3 Pro Update.

    (I am not 100% sure if I really am still on 22Q2 ... though I updated recently ?)
    Will need to start the PC and examine.
  • Tom Foster
    edited November 14
    Just checking - when you say 22Q2, 22Q3, you're nor refering to Brics versions? Cos I had related problems since the last v22 update (cured with v23).
  • No, that was the current Pro Version naming scheme of AMDs GPU driver.

    I do really not know what all offered GLSWAP mode options mean.
    But I think if someone notices problems on screen,
    it may be worth to try any other GLSWAP mode ....

    AFAIK only,
    for me, "0" seems to be ok, "2" does not work without issues.

    Maybe at one point I will cycle through all of these modes to
    see if I can detect any performance differences.
  • Just checking - when you say 22Q2, 22Q3, you're nor refering to Brics versions? Cos I had related problems since the last v22 update (cured with v23).

    No 22Q3 refers to the version of the AMD Pro driver. They release an update every quarter. FYI 22Q4 just released has the same problem.
  • I do really not know what all offered GLSWAP mode options mean.
    But I think if someone notices problems on screen,
    it may be worth to try any other GLSWAP mode ....

    AFAIK only,
    for me, "0" seems to be ok, "2" does not work without issues.

    Thanks for the suggestion. Unfortunately I have tried all GLSwapModes with no difference in any of them.

  • Yes, in your case it seems like a real driver bug or incompatibility
    with Bricscad.

    But meanwhile I checked the PC. As I guessed, I do already had the
    22Q3 Pro driver installed and I do not see problems in 2DWireframe !?
  • Yes, in your case it seems like a real driver bug or incompatibility
    with Bricscad.

    But meanwhile I checked the PC. As I guessed, I do already had the
    22Q3 Pro driver installed and I do not see problems in 2DWireframe !?

    2D wireframe works for me also, but in building a BIM model I need a shaded 3D visual style.
  • Is it file related for you ?
  • Hi guys, I finally solved the problem. If you turn on Transparency Display in Settings it fixes the issue. Also, V23 doesn't do it OOTB.
  • Great.

    But AFAIS this is the default setting in both V22 and 23.
    I have it on on both.
    I haven't noticed that Setting before.

    Great that you found that Setting.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!