V12 Font Display


Hi. Some drawings created in V11 are displaying unusual fonts in V12. Mostly the Letters are filled with colour, no  hollow spaces at all. Unusal angles are evident where a letter may finish e.g. across the ends of an L or E. 


Any ideas what may be causing this ?

Comments


  • Ok, I have a temporary fix using isocp and romans. The offending font was Arial.

  • did you have same fonts in
    /opt/bricsys/bricscad/v11/Fonts/ and /opt/bricsys/bricscad/v12/Fonts/

    you can make a link or add some ~/cadfonts directory in srchpath bricscad variable

  • Greetings

    I have ubuntu 11.10 with gnome3 and I have the fonts of windows installed in ubuntu, but in the new bricscad V12 some texts appears rare or strange,
    I do not why?

    I installed again the version V11.3-16 and all the fonts looks normal, also I copy the fonts of bricscad V11 to V12, but nothing.
    What can I do in the new version V12?

    thanks a lot

    jorge
    imagePantallazo del 2012-02-28 14:03:03.png
    imagePantallazo del 2012-02-28 14:01:47.png
  • I did not experience this, so just a guess:
    Maybe the new text rendering algorithm is to blame (see excerpt from the release notes below), did you check different settings?

    SR29641, SR32973 - TTF QUALITY: Improved text rendering on Linux. Now TEXTQLTY variable is used in the following manner:
    • TEXTQLTY < 49: old rendering method is used. The actual value is not used.
    • 50 <= TEXTQLTY <= 100: new approximation algorithm for Bezier curves. Greater values imply better quality but more points for the approximating polyline so performance-wise a lower value is recommended. </li>
    • TEXTQLTY = 50 is the default value

  • Greetings

    I have ubuntu 11.10 with gnome3 and I have the fonts of windows installed in ubuntu, but in the new bricscad V12 some texts appears rare or strange,
    I do not why?

    I installed again the version V11.3-16 and all the fonts looks normal, also I copy the fonts of bricscad V11 to V12, but nothing.
    What can I do in the new version V12?

    thanks a lot

    jorge

    Very similar to my problem Jorge. Very similar. We may have unearthed something.


  • Example of fonts as displayed on R12

    imageBricscad Fonts.jpeg
  •  I am use only .shx fonts as far as I understand you use .ttf
  • Dear Brian, Jorge,

    You are kindly encouraged to file a support request about this issue, thus giving Bricsys developers the chance to reproduce and investigate it as soon as possible.

    As Knut pointed out, the problem may be related to the new text rendering algorithm. Setting TEXTQLTY variable in the 0 .. 49 interval was meant as a fall-back method in case of trouble with the new technique, however that may not be as feasible as was first envisioned, as TEXTQLTY is a drawing attached setting not registry resident which makes it a difficult to undo change.

    Best regards,
    Alexandru Branescu.

  • So far, I couldn't reproduce the problem on Ubuntu 11.10 (I also use Arial in some drawings). On the other hand, I wasn't able to spot any difference between TEXTQLTY=1 and TEXTQLTY=99 (after regenerating, also tried to switch QTEXTMODE on and off to force recalculation) - shouldn't this have a visible impact on resolution?
  • Hi Knut,

    I can also also reproduce what you described. It turns out you have to set TEXTQLTY variable, save the current drawing containing MTEXT entities, restart Bricscad and open that drawing again. After this, the TEXTQLTY value will be used for the rest of the current session, irrespective of other consecutive opened drawings with different TEXTQLTY values.

    I agree this is not what was intended and we need to reevaluate its behaviour. The variable has been defined for some time but never used until now, so that may explain these slight issues.

    Hint: To better appreciate the level of detail used for text rendering at a specific moment you can use _txtexp command to explode the _mtext entities.

    Best regards,
    Alexandrub Branescu.
  • Ok, I see... this can clearly not be left as is - I think it is of little importance if this setting works per drawing or application-wide, but changes should take effect immediately.
    At least (the way it works now), it should give people who experience problems a quick workaround by setting TEXTQLTY to the desired value in their template drawing.
    I checked with TEXTQLTY=1 (doesn't look very nice, but not as coarse as expected) and TEXTQLTY=99 (drastically increased drawing load time), and am now back to the default of 50.
    IMHO, this setting would make most sense if it would allow to reduce the text quality even further, to speed up heavy drawings as much as possible.

  •  This is not a fix for the problem, but a way to deal with it. I had severe problems with MS fonts in V11; at least half of my drawings would crash very shortly into a session or would not open at all. Very frustrated with the whole thing, I removed the MS fonts from my system and replaced them with Liberation fonts, which are close enough in size in spacing that swapping the fonts in a drawing did not screw up the appearance of the drawings. In each drawing that used the MS fonts (usually Times New Roman,) I had to redefine the style with "STYLE" command, a few second procedure. -- I no longer have font problems in Bricscad, the Liberation fonts work well and look good in my other applications and I've removed one of the last vestiges of MS on my machines. Couldn't be happier.

  •  Note - I had to load the Liberation fonts on my MS machine, which was no problem. Also needed to talk one engineer through the process of adding them to his machine too, so he could see my drawings as I intended them, but that wasn't a problem either.
  • Hi everybody

    Now we got the new version of bricscad linux V12.1.21-1 but my problem with the fonts continue, I will report this bug after of this comment, but I want to share with all of you an interesting behavior.

    The problem with the fonts only appears if the high of the text is <= to 0.7<br>
    if I change the high of "any text with the problem" with values up to 0.7, the text looks good. if I change the sacale or the high again down from 0.7 the problem appears again.  The only way that I found to solve this was writing the text notes with high=1 and convert the text into a block entity, after that I can scale the new block and the text still fine, of course if you explode the block the thext will suffer again the problem.

    Well, I don't have a solution for this, but I wanted share with you this situation with the texts,

    regards to everybody
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!