Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can Bricscad V13 work on Debian Wheezy 64bits?

I've managed to install BricsCAD V13 on Debian Wheezy 64 bits, but at runtime i got an error on libc.so.6 not being glibc 2.15.  Since Debian stopped on glibc 2.13 I cannot find a way to fix this.

Anyone had sorted out this problem without screwing the whole system by installing 2.15 libraries from the dev sources?

Comments

  • I use Bricscad V12 on 64-bit Debian Wheezy. I did have earlier versions of V13 working as well, but that must have been before libc6 had to be version 2.15. Maybe the staff could tell you the most recent version of V13 before the dependency changed to 2.15?

    2.15 is the version that Ubuntu uses, and the Bricscad Linux package is developed from Ubuntu. In Debian testing/jessie you will find version 2.17.

    I am not an expert, but it seems like it will be a difficult problem to solve. If you upgrade to jessie, you will get 2.17, but who knows if that will be sufficient? And you probably don't want to upgrade to jessie.


  • The problem is in the version of Bricscad, Bricscad version V13.1.19-2-en, work in Debian Wheezy but now you can download Bricscad-V13.2.11-1 is not. You need to get a Bricscad version V13.1.19-2-en.
  •  Yes, I agree with Robert. Earlier versions of V13 work on Debian Wheezy. I am currently using V13.1.19.
  •  Yes, I agree with Robert. Earlier versions of V13 work on Debian Wheezy. I am currently using V13.1.19.


    I wonder if I can get V13.1.19, it is not on selection of older versions ....
    Is there anyone who could help?
  • Here is a download link of V13.1.19:

    http://www.bricsys.com/open/common/download.jsp?i=3152

    V13.1.19 was built on Ubuntu 10.04 LTS
    V13.2 and later were built on Ubuntu 12.04 LTS

    Debian Wheezy uses an older glibc than Ubuntu 12.04, so there is no solution possible for running BricsCAD V13.2 or later on Debian Wheezy.
  • BricsCAD V14.1.06 (64-bit version) installed smoothly on 64-bit Debian Jessie.
  • Here is a download link of V13.1.19:

    http://www.bricsys.com/open/common/download.jsp?i=3152

    V13.1.19 was built on Ubuntu 10.04 LTS
    V13.2 and later were built on Ubuntu 12.04 LTS

    Debian Wheezy uses an older glibc than Ubuntu 12.04, so there is no solution possible for running BricsCAD V13.2 or later on Debian Wheezy.


    Sorry for PM to support!
    I couldn't believe that I couldn't answer last night.
    I was building several machines with Ubu 10.04 LTS,   12.04 LTS,  Deb 4,  Deb. 5, Deb 6 and Deb 7 for testing purposes and
    trying BricsCAD, all amd64, none in German.
    If some work is needed to translate, I could help, i you want.
    As Linuxers know IT-English only. CADuser prefer their own language.
  • BricsCAD V14.1.06 (64-bit version) installed smoothly on 64-bit Debian Jessie.


    With which dektop?
  • hello, i have a equal problem. i install bricsv16.2.18 on debian. a app crash after select the template 2d. what can i do?
This discussion has been closed.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam