Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

How to increase resolution of STL export?

I am experimenting with .stl export and find the resolution rather poor. Cylinders are faceted and typically have 30-40 facets. In other CAD software the default is 80. Is there a way to improve the resolution in BricsCAD?

Comments

  • When exporting 3d solids to STL, curved faces will indeed become faceted.
    The default way to control the facet resolution ( = the smoothness) is to use the FACETRES system variable: default value is 0.5, minimum = 0.01 (coarse) - maximum = 10 (very fine)
    Using MODELERPROPERTIES it is possible to override Facetres and control the smoothness by using different parameters, but in general it is recommended to use facetres because it is simpler.
  • Thank you Hans.
    BTW: I did do a 'Settings' search for 'resolution' and did find FACETRES but since the description does no mention 3D export I concluded this variable to not be applicable.
  • A small addition to this topic. I would like to point out that if spaUseFacetRES is set to 1 not all other spa* variables are overridden. With all spa* variables set to their default values and the FACETRES set to 5, in some cases there are holes in the surface of the STL output. Reducing (counter intuitive) the spaMaxNumGridLines value can solve this.

    Model: Box 2x2x1, with 3 edges filleted R=0.2

    FACETRES=5
    spaMaxNumGridLines=512 (default)
    => Holes in STL

    FACETRES=5
    spaMaxNumGridLines=64
    => STL is OK

    See attached image for STL with holes (screenshot from Netfabb but importing the file in Blender confirms the holes).

    In my model I have cylindrical faces with a radius of 20 and of 0.2. I am having trouble finding the ideal settings for the STL output. I am interested in any advice other users may have.
    imageFillet3D_DEF_FACETRES05.png
  • ... OK, I think I have found the 'ideal' settings I was looking for.

    I was playing around with spaMaxFacetEdgeLength and spaNormalTol but these variables do not give me the desired result. Setting spaMaxFacetEdgeLength to non-zero leads to the unnecessary division of a single cylinder facet in numerous triangular faces instead of just two. Changing spaNormalTol to 3.6 means that all cylinders will have 100 facets and I want a cylinder with a smaller radius to have fewer facets.

    The solution is to change the spaSurfaceTol variable. For the mentioned radii (20 and 0.2) a value of 0.005 works well. The spaNormalTol is set to the default of 15 ensuring that a cylinder has at least 24 facets. The spaSurfaceTol value of 0.005 forces larger cylinders to have more facets.

    So all modeller settings are set to default values except:
    spaUseFacetRES=0
    spaSurfaceTol=0.005
This discussion has been closed.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam