Shift to lock to an axisz

Please tell me what I'm missing -
I want to be able to start a Move operation in the z direction, press or hold Shift to lock all movement to that axis, and snap to anything way away in the x or y direction to define the z-depth of the Move To point.
What happens is that the axis lock seems to flip to any of the 3 axes at random, half way through the move, and as often as not the Move To point is just the point I snapped to, as if I had made no attempt to lock to any axis.
Another problem with Shift press and hold (as opposed to Shift press and release) is that any pan/zoom gets converted to a rotate (unfamiliar, as I'm using a SpacePilot mainly, not BricsCAD's rotate commands).

Comments

  • Your interpretation of 'Ortho Mode' is not correct. Mind you the explanation in the Help is not completely correct either.

    Ortho Mode restricts the movement of the cursor. The movement is kept parallel to either the X, Y or Z-axis of the current UCS (the Help does not mention the Z-axis). As you move the cursor around the CAD program decides which axis to use for the current position. Ortho Mode does not lock to a single axis.

    Maybe using point filters is the solution here. If this is something you do frequently, creating a macro may be convenient:
    [code].xy;@;[/code]
  • The  ORTHO mode is a somewhat 'fossil' feature which is meant to be used in 2D drawings, or better not at all. It is recommended to use POLAR and STRACK (Entity snap tracking) instead. If POLAR mode is selected, ORTHO is switched off automatically anyway. The problem with ORTHO is that entity snaps ignore ORTHO, so you cannot 'block' the movement to an axial direction and then snap to a point. I did a few tests, and as far as I can see the hit-the-shift-key procedure correctly locks/releases the current POLAR or STRACK tracking lines. Entity snap points are projected onto the locked tracking line.
  • Confused with STRACK?

    Maybe look at Parallel osnap. Requires Entity Tracking (STRACK) to be on to work. Similar to DUCS you can lock your chosen tracking line by pressing Shift (tracking line will change colour). There is a video Entity Tracking here
    http://bricsys.tv/m/?drawing-accurately-part-2-m134


    Regards,
    Jason Bourhill

  • I must admit that I tend to rely on ORTHO. Old habits...
  •  I also use Ortho quite a lot.  To me the object tracking always has a certain amount of uncertainty   At the moment you click, you might shift slightly and loose the tracking.  Entity snaps have also lost some of their certainty over the years.  Many years ago, if you explicitly choose an entity snap, and then didn't successfully get it, AutoCAD would beep.

    -Joe
  • Also make sure you have not activated "Ignore entity snap elevation" in settings. This value follows the file so you may have to check it. It has given me a lot of frustration. Another tip would be to pick the stuff you want to move then hit the "look from" circle to se it from the side now you can move it in z graphically.
  • At the moment you click, you might shift slightly and loose the tracking.
    That's when you hit the shift key to lock the tracking line.
  • "That's when you hit the shift key to lock the tracking line. "
    ... and that's when instead of the beep confirmation, the tracking line will change color to confirm it has been locked...
  •  Thanks for the shift-locking comment. I had not been aware of that.

    -Joe
  • I must be doing something wrong.
    I have esnap & strack on - I turn ortho off (or on, for that matter) and shift makes no apparant difference,

  • Shift works well when in POLAR Mode.

    ORTHO locks by itself but not very reliable.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!