Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Can't catch the Quad


Hi all,

I'm test driving the latest BC release on an Intel NUC D54250 running Ubuntu 16.04, having a Wacom Intuos pen tablet attached to it as my pointing device. So far things work generally OK. In fact, ever since I got rid of the graphical glitches through the use of the correct GL Swap Mode setting, I've been fairly impressed with BC. I currently have a little problem however: I can't seem to use the Quad Cursor. When I draw a line, preselect/select the line, wait for the Quad Cursor to appear to the right of the cross hair, and then move the cross hair towards the Quad Cursor, the latter quickly disappears to subsequently reappear next to the new position of the cross hair. In other words: it runs away from the cross hair, and cannot be caught.

I tried playing with some of the Quad Cursor's settings (e.g. Quad hide margin), but to no avail. Does anybody have a clue as to how to catch the Quad?

Alexander

P.S. Incidentally, I noticed that opening the Settings window from the status bar hugely increases the BC CPU load (while this doesn't happen if I open it via the menu bar). I'm not sure if this is worth reporting as a possible bug.


Comments

  • Did you try increasing the value for QuadHideDelay?

    Regards,
    Jason Bourhill


  • Hi Jason,

    I did... unfortunately, most of these settings do not appear to have much of an effect. I have the feeling that my pen tablet's operation plays a dubious role here. I just managed to find a way to get a hold of the Quad, which entails:

    1. selecting a drawn object, e.g. a line (by touching the tablet with the pen tip at the location of the object)
    2. waiting for the Quad to appear to the right of the cross hair
    3. moving the cross hair somewhat away from the selected object, so a selection can be started
    4. starting a selection (by touching the tablet with the pen tip, and drawing/expanding the selection window in the direction of the Quad, which now does not move or disappear)
    5. moving the movable point of the selection window that is being drawn over the Quad, which then shows and responds to the presence of the 'mouse cursor arrow'.

    I'll investigate further tomorrow. Perhaps BC is simply not intended to be used with pen tablets... they are kind of peculiar, and not all programmers take their existence into account. Ubuntu's auto-hiding launcher, for instance, is, once hidden, impossible to retrieve with a pen-tablet operating in absolute mode, since the pointer can't move over/beyond the edge of a screen, which is counted upon by the software to make the launcher reappear.

    Best regards,
    Alexander

  • Interesting.
    Same problems on Mac when using a Mouse,
    Quad will hide before I can reach.
    But opposed to you the Quad stays much longer when I use my
    Wacom Cintiq Pen input.
    (Unfortunately that does not work well for selections)

  • We have experienced something similar at our office workstations (Debian stretch with openbox window manager and tint2 panel). In our case the misbehavior of the quad is only present if we have a panel on the desktop taking up/reserving some of the screen space. When we disable our desktop environment panel, or hide the panel completely (its not ok of it still reserves a few pixels when hidden) this solves the issue for us.

  • ^ very interesting catch.

  • Has this been solved / anyone found a workaround for Mac? Essentially I can use the Quad if I have no objects selected, but if I have anything in my selection set the quad appears but "runs away" from the cursor.

  • I have still a SR running.
    It was reproducible, but only in rare cases (moving cursor very slowly)
    while it happens for me all the time no matter which speed.
    It works well on Windows for me.

    It seems Bricscad Mac reacts to every little (accidental) cursor position
    change. That leads to all kind of things like restart Selection's TAB cycles
    or lose Quad.
    For me it also looks like when the Quad appears for the first time it is not
    already ready. It often blinks to appear a second time.
    But that could be just the same cursor sensitivity problem.
    So I normally try to give it some milliseconds first where I press the mouse
    down to not move and wait a bit until I try to reach the Quad as fast as
    possible so it can't escape.
    (Maybe a bit esoteric) :smile:

    And I saw that it sometimes works as it should, or at least better, for some
    of my Solids while others need 15 attempts each time.
    But I could not find a rule for this behavior like it would work better for
    elements in front vs far behind, the angle they are pointing to you or such
    things.

    It is interesting that it works nearly problem free with my Wacom Pen Input
    although there is definitely more cursor shaking. But maybe Wacom Driver
    filters that out a bit.
    I see not much difference between different Mice, standard vs with proprietary
    drivers. Maybe a bit in their speed behaviors or accuracy.

  • Now i see it in Bricscad for Linux too.
    (+ some other cursor redraw and behavior issues too)

    While I think the Quad-disappears-problem on Linux (V17)
    is not as big as on macOS.
    It mostly worked after a 2nd attempt for me.
    Not like 4-15 attempts on macOS.

  • edited April 16

    Setting :
    QuadShowDelay > very short
    helps a bit while
    QuadExpandTabDe > longer
    helps when you diagonally cross other Tabs while trying to reach your
    Tool Icon in a tabbed section, without switching to unwanted Tabs.

  • This has been fixed in Bricscad v18. Problem solved.

  • On Mac too.

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam