Screen rotate

 I am using MacBook Pro with Bricscad Pro 2016. Works great except when pan and zoom it will rotate screen, no matter how careful, annoying. Is there a way to lock screen in the 2d workspace so screen will not rotate?


  • It's not really a solution and I have the same problem. What I found was that if I pinch zoomed out it wouldn't register as a rotate as often. So whenever I needed to zoom in I would zoom out a little then immediately zoom in. I tried looking around in settings to see if I could find something. I even tried disabling two finger rotate in the OS X settings.

    BricsCAD should disable two finger rotate on the trackpad or make some tolerance adjustments to the program. 

    It sucks for those moments I need to work on a drawing and I forget my mouse. 

    I hope this helps. 
  •  It does suck, I tried your suggestion with no luck. I guess I should have tried BricsCad on my MacBook Pro before purchasing (just my iMac with mouse). I cannot figure out why they think we need to dynamically rotate in 2d drafting. I do not have this issue when I use AutoCad on my MacBook Pro.
  • I made BricsCAD more bearable with a trackpad by adding a custom key shortcut. You have to press enter after you are done with the command. I'll look into this more. It's still and improvement. 

    However, for panning you can just hold the command key at any time and when you move the mouse around in view space it will pan.

    I attached a video on how I made my shortcut. 


  •  I made the shortcut, works very nice, so pan with the command key, okay for now. I did contact bricscad about this issue, hopefully they will fix trackpad support. Thanks
  • A few months old now, and perhaps the original poster has a working solution by now. However, thought I should throw in my suggestion in case anyone else reads this.

    BTT - BetterTouchTool app for Mac. A trackpad/mouse/keyboard assignment/configuration tool, and best of all - they can be made "application specific".

    It took two seconds after setting up Bricscad on Mac, before I was looking for the option to turn the trackpad "two-finger-rotate" off. Really no use for it when in 2D 99% of the time. Couldn't find it, so google brought me here - and realised there is no option for it.

    So... Opened BTT - added Bricscad to the "specific applications" list - and configured the "two-finger-rotate" - to do nothing. Voila :)

    If I where to name one tool I could not live without on a MAC - it would be this one. (Similarly, on a Win-PC, it would be AutoHotkey).

    At least - this was my preferred solution :)

This discussion has been closed.