Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Lighting issue

Never before had a problem with lighting on my 3D models or assemblies. Always used the default lighting you get when you start a new drawing with the wizard.   Always able to tip the model with "real time motion", and see the underside.   

Yesterday I created a mechanical assembly with V17.  The top of the assembly is illuminated just like normal.  But if I tip it to look at anything on the underside, it is totally dark.  Can't see a thing.  I tried placing a light below (flashlight).  That helped somewhat.  But then I noticed that nothing is visible on the edges.  They are dark too.   Do I need to shine a flashlight at each edge, and WHY?"  What has changed?

Comments

  •  Here is a guess from a non-expert.  Possibly some other program (or some other glitch) told your video card to render scenes a certain way, and it has retained that setting.  A reboot may solve it if that is the case.

    -Joe
  • I would check that DEFAULTLIGHTING = 1. If you've created your own lights you may of inadvertently turned it off.

    If this doesn't fix your problem, then it may be something to do with your global material. To fix this, you start a new drawing using one of the default templates, then in the Drawing Explorer copy the global material definition from the new drawing to your drawing, and when prompted select 'Copy and Replace'.

    Regards,
    Jason Bourhill
  • Joe, Jason,
    Thanks for ;your reply.  Unfortunately, a restart of my PC did nothing to resolve the problem. DEFAULTLIGHTING was already set to "1".  I started a new drawing with the default template and copied over the global material definition.   My model is still black on the underside, meaning it is impossible for me to edit the bottom side of the assembly.  Locating spotlights (actually "weblights") beneath the assembly allows me to see the underside, but the lights cause a lot of glare, which also interferes with editing.   And they occupy the screen..  So I still can't do the editing.
  • Hi Jim,

    WEBLIGHTs require a far amount of setup to use. It could be quite easy to get a setting wrong, which would give the results you're seeing. With weblights the primary check would be the value of LIGHTINGUNITS, either 1 for American ft-candles, or 2 for International Lux.

    I would try turning your weblights off, or removing from your drawing to see whether this returns your display to normal. If it does, then it is something to do with your weblight settings causing the problem. Unless there is a specific feature of weblights you're looking for, you may find it easier to use a standard light setting instead.

    Regards,
    Jason Bourhill
  • Jason,

    Thanks.  But you don't understand.  I only created the web lights in an attempt to fix the problem.  And they DO illuminate the bottom of the model.  But the moment I turn them off, the underside of my model returns to pitch black.   I have never had this issue with any of my drawings.  The default lighting was sufficient.   See attached screenshots......

    I may have zeroed in on the issue, but not sure how to fix it....I opened up the default template, and looked at the default sun.  It was set to WHITE, but OFF.  When I looked at the default sun for my assembly it was set to grey (and ON).  I changed it to OFF.  Surprisingly the assembly was BETTER illuminated!   I tried to change the color to white, but it won't accept any changes.   How to fix this?  

     
    imageSun (new template).jpg
    imageWeb Lights Turned On.jpg
    imageSun (my assembly).jpg
    imageTop of Assembly.jpg
    imageAssembly Tilted Up..jpg
  • Update on this lighting issue. I start all my drawings from a couple templates (*.DWG) that contains a layout with a border, title block and viewport, as well as some text and dimension styles and a few standard layers. I save the read only file to another name, and off I go.

    I discovered that when I opened a new drawing with the drawing wizard, it DID allow me to alter the color of the "Sun" lighting. Files started from my templates locked out this change. I created new templates to use, and that solves most of my problem.

    However, the interesting thing is that the default setting for the Sun is "OFF". If I turn the Sun "ON", my model gets darker. That happens regardless of the lighting color. Have to do more investigation of this.....

  • I am wondering if a particular rendering problem, that showed up today, is another example of some setting getting messed up without the user knowing how it happened.

    In my case, it is when I use the orbit command or change the viewpoint using one of the preset views in modelspace. On simpler models the orbit would work very well, and the rendered image would easily keep up with my manipulations. However, now, even extremely simple cubes turn extremely pixelated. Once I change view points, it takes perhaps 10 seconds for the rendered image to finally change to an appropriate resolution.

    To make a guess at the coarse resolution, perhaps 240x240 pixels. On anything but a simple cube, this sort of resolution makes it almost useless to use the orbit command.

    I have exited BricsCAD, and restarted it. I have even rebooted my computer, without it changing back to the way it was. So, whatever made the change, it was permanent.

    Is there a setting in BricsCAD that controls this? Might it be that some other program changed the video settings, and BricsCAD has no control over this aspect of the rendering.

    -joe

  • An update on my own pixelation issue. I see now that things are worse than I thought. Everything that I do, even start to draw a line causes this pixelation to start, and then it will not allow me to proceed until the pixelation has stopped, perhaps 5 or 10 seconds. This occurs in any drawing where I have set any view to be a rendered view. When I am in paperspace, the entire layout tab goes pixelated, not just the rendered viewport.

    -Joe

  • @Jim Canale said:
    Update on this lighting issue. I start all my drawings from a couple templates (*.DWG) that contains a layout with a border, title block and viewport, as well as some text and dimension styles and a few standard layers. I save the read only file to another name, and off I go.

    I discovered that when I opened a new drawing with the drawing wizard, it DID allow me to alter the color of the "Sun" lighting. Files started from my templates locked out this change. I created new templates to use, and that solves most of my problem.

    However, the interesting thing is that the default setting for the Sun is "OFF". If I turn the Sun "ON", my model gets darker. That happens regardless of the lighting color. Have to do more investigation of this.....

    You can change the sunlight color only if LIGHTINGUNITS = 0. If the sunlight is too weak, set the 'Intensity factor' to a higher value.
    Please note that all lighting related variables and settings are saved in the drawing. Therefore the lighting settings of the template used to create a drawing matter.
    When all lights in the model, including the sun are disabled, the default lighting is used. Set DEFAULTLIGHTING = 1 to replace all user defined lights (including the sun).

  • What Joe describes sounds very much like the GPU hardware is no longer used to calculate the 'rendered' display, instead it is done in software mode, which is (very) much slower, and starts with an approximated pixelated image which is gradually refined till completion.
    This is controlled by a setting 'RenderUsingHardware'.
    The first time BricsCAD runs on a system, it verifies if the GPU is supported by its render engine, and sets the value of RenderUsingHardware accordingly.
    From Joe's description, I seem to gather that this setting has been modified.

  • Thank you Hans for the idea. I did just check, and the rendering was set to "Prefer hardware rendering". I did try "Hardware rendering only for testing" and noticed that as soon as I open a drawing, the command prompt says, "Hardware rendering is not supported on this machine. BricsCAD is falling back to software rendering."

    So either something has broken BricsCAD's ability to see the hardware rendering ability, or the hardware rendering software itself is broken.

    I have just tried a student edition of SolidWorks, and it renders fine. So, I know the hardware is working.

    I will start by re-installing the video drivers. Then, I guess the next step is to re-install BricsCAD.

    -Joe

  • @Joe Dunfee:
    I would try a new profile first.

  • I have done the following, all with no change to how BricsCAD behaves. It still reports "Hardware rendering not supported".

    1. Re-Installed video drivers.
    2. Repaired Bricscad.
    3. Uninstalled then re-installed BricsCAD. (being sure to set BricsCAD to run as administrator)
    4. Change to the Default user profile and restarted BricsCAD.
    5. Created a new profile, and changed to hit, then restarted BricsCAD.

    I will contact support.

    -Joe

  • @Louis Verdonck said:

    You can change the sunlight color only if LIGHTINGUNITS = 0. If the sunlight is too weak, set the 'Intensity factor' to a higher value.
    Please note that all lighting related variables and settings are saved in the drawing. Therefore the lighting settings of the template used to create a drawing matter.
    When all lights in the model, including the sun are disabled, the default lighting is used. Set DEFAULTLIGHTING = 1 to replace all user defined lights (including the sun).

    Thanks Louis. Jason mentioned this variable earlier. But in my case, the variable was already set to "0", and I still could not change the Sun lighting color. Also with the variable set to "1", the default lighting was not illuminating the bottom of my assembly. To correct the problem, I opened a fresh drawing with the wizard and copied all my 3D models to it. I've had some problems with files getting corrupted in various ways, and also variables being changed at random. The AUTOSNAP variable is particularly sensitive to this.

  • @Joe Dunfee said:
    I am wondering if a particular rendering problem, that showed up today, is another example of some setting getting messed up without the user knowing how it happened..........

    -joe

    Joe,

    Was not my intention to ignore you. I've been so busy, I didn't see your post. I agree with you about settings. I have encountered problems with variables changing "on their own". The biggest problem I have seen has been with AUTOSNAP. I used to reset it almost every day when I when I was running V15. Haven't seen the issue since I moved to V17. (we bypassed V16) Can't say that V17 was the solution to my problems, as I also received an upgraded machine with a 64 bit OS at the same time.

    Wish I could help you with your pixelation issue. I have had issues with video drivers in Linux. Going to an OLDER version sometimes helped.

  • My pixelation issue is resolved for now.
    The key step that seemed to fix it was installing the recommended driver. BricsCAD was now behaving properly. However, that version of the driver causes many other problems for me. Specifically, nearly all dialog boxes open off screen in my multi-monitor set-up. And my desktop is not all visible in my TV/monitor that I use for my 2nd monitor, because of overscan on the monitor. I cannot make use of the desktop scaling on this version, because its adjustment graphics are all in the wrong place. This is not a dialog box, so I cannot even re-center it using manual methods. Plus, all dialog boxes open off screen.

    The good news is that re-installing the latest drivers did not wipe out the fix to whatever caused the hardware acceleration to get turned off.

    I think the next step will be a new computer. This one is over 6 years old. And while its power is still sufficient for my needs, perhaps getting a fresh start will solve some problems. The company has paid more than the cost of the new computer for my time trying to resolve this video problem, and other video problems that have crept up over the past year.

    -Joe

This discussion has been closed.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam