Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

V16 install: glibcxx-3.4.15 & CXXABI_1.3.5 not found

Hello,

I have been using BricsCADv12 for some time and I just obtained a license for v16.
After installing, running bricscadv16 produced a long series of errors - all of which consist of one of the following three:

/opt/bricsys/bricscad/v16/bricscad: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /opt/bricsys/bricscad/v16/bricscad)

/opt/bricsys/bricscad/v16/bricscad: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /opt/bricsys/bricscad/v16/bricscad)
No package glibcxx available.

/opt/bricsys/bricscad/v16/bricscad: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.5' not found (required by /opt/bricsys/bricscad/v16/libwxgui.so)
No package cxxabi available.

=======
My system is Linux CentOS 6.6:
rpm -q centos-release
centos-release-6-8.el6.centos.12.3.x86_64

I downloaded BricsCAD-V16.2.18-1-en_US.x86_64.rpm and installed it with no errors:
yum install BricsCAD-V16.2.18-1-en_US.x86_64.rpm

Yum says my system has:
Package glibc-2.12-1.192.el6.x86_64 already installed and latest version

Trying to use yum to get the other two says not found.

I was able to get the source and compile it for glibc-2.14. Exporting the path removed the glibc-2.14 error when starting bricscad:
export LD_LIBRARY_PATH=/opt/glibc-2.14/lib

As for the other two libraries, I have been reading that I cannot obtain them in CentOS 6, but need 7. For various reasons, upgrading to 7 on this machine at this time that is not an option.

Do you have any suggestions as to how I can run Bricscadv16 on my CentOS 6 system?

Thank you for considering this.
Rees Acheson

Answers

  • I see that there has not yet been a reply so I ask a related question:
    What is the highest Bricscad version that will run in CentOS 6?
    And if there is one, will the v16 key that I have work with it?
    Thanks.

  • If I'm not mistaken, I believe a license key can be used for any version below it's current version. As for the highest version supported on CentOS 6, I would just install V15 then see if it starts. If it does not, then uninstall it and try the next one down. It looks like V13 is the oldest release you can download.

    Bricsys should look into putting there program into a package manager like snap, appimage, or flatpak. As I believe it would help with all the different Linux environments out there.

This discussion has been closed.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam