Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

MOUSE WHEEL ZOOM SLOW

Hello
Bricscad v17 pro user.

  1. Does the speed of the mouse wheel zoom / out be the reaction speed? Delayed phenomenon occurs. Especially copy or move
    Selecting an object and zooming out will get worse.
    I can not solve it even if I search on the internet. In other CAD programs,
    This is a problem I did not know. This is an important issue for me because of the slow progress in quick drawing work.
    It does not seem to be a hardware problem,
    I do not have it. Is it a brickscade issue?
    There is no answer even if I ask the homepage.
     
  2. Dynamic input questions. When drawing lines or other drawings, dynamic input box appears, but there is no slippage, stretch, or move.

SYSTEM
CPU - AMD R5 1600
GPU- GTX 1060
RAM- 8G

THANK YOU

Comments

  • edited June 2017

    I believe your "speed" issue might be a Windows related problem not a BricsCAD related problem. Have you checked your mouse settings?

    Go to Control Panel > Mouse.

    If you are instead referring to the mouse "zoom factor" that is set within BricsCAD.

    Setting the Zoom Factor variable.

    Type **zoomfactor** in the command bar, then press Enter.
    You are prompted: New current value for ZOOMFACTOR (3 to 100) <current value>:
    Type a value between 3 and 100 in the command bar, then press Enter.
    
  • Another possible factor is the size of the drawing. By size, I don't mean units of distance, but rather how many objects are in the drawing. If it simply overwhelming your system, then one way of addressing the problem is to increase the zoomfactor. This means the screen will zoom at a greater increment for each "click" of the scroll wheel. So, zooming will be coarser, but perhaps faster, since the computer won't have as many in-between steps to render.

    You might also try changing your rendering style if it is a 3D drawing that is using any of the rendering styles besides a 2D one.

    There are a few other things that affect rendering speed. Settings like viewres (which affects curve resolution) and qtext (if there is a lot of text) are other settings to play with if you have a large quantity of those kinds of objects.

    -Joe

  • Viewres as a culprit? In what way specifically?

  • I just got a little more education on this issue, when I looked up the Viewres setting. It seems that, as the integration of video processor cards has made progress over the years, there are some new settings that essentially made viewres obsolete. Here is a note from a 2012 thread on a CAD forum. http://www.cadtutor.net/forum/archive/index.php/t-75166.html?s=f623caf20747694f156314ed12e3b78c

    I checked and BricsCAD does support the additional settings, and the defaults are the same as on AutoCAD. The Viewres has no funtion if the Wiparc setting is on.

    =================
    VIEWRES
    Sets the resolution for objects in the current viewport.

    Summary
    The model is regenerated.
    VIEWRES controls the appearance of circles, arcs, splines, and arced polylines using short vectors. The greater the number of vectors, the smoother the appearance of the circle or arc. For example, if you create a very small circle and then zoom in, it might appear to be a polygon. Using VIEWRES to increase the zoom percentage and regenerate the drawing updates and smooths the circle's appearance.
    http://docs.autodesk.com/ACD/2011/ENU/images/PTDCPM/Hammer-ACR/acw2206u.png

    NoteIncreasing the zoom percentage in VIEWRES may increase the time it takes to regenerate the drawing.

    When a paper space layout is made current for the first time and a default viewport is created in the layout, the viewing resolution for this initial viewport is the same as the viewing resolution for the Model tab viewport.
    The VIEWRES setting is saved in the drawing. To change the default for new drawings, consider specifying the VIEWRES setting in the template files on which you base your new drawings.

    =================
    WHIPARC
    Type:IntegerSaved in:RegistryInitial value:0

    Controls whether the display of circles and arcs is smooth.
    0) Circles and arcs are not smooth, but rather are displayed as a series of vectors
    1) Circles and arcs are smooth, displayed as true circles and arcs

    =================
    WHIPTHREAD (only If you have a Multicore Computer)

    Type:IntegerSaved in:RegistryInitial value:1
    Controls whether to use an additional processor to improve the speed of operations such as ZOOM that redraw or regenerate the drawing.
    WHIPTHREAD has no effect on single processor machines.
    0
    No multithreaded processing; restricts regeneration and redraw processing to a single processor. This setting restores the behavior of AutoCAD 2000 and previous releases.
    1 ) Regeneration multithreaded processing only; regeneration processing is distributed across two processors on a multiprocessor machine.
    2 ) Redraw multithreaded processing only; redraw processing is distributed across two processors on a multiprocessor machine.
    3) Regeneration and redraw multithreaded processing; regeneration and redraw processing is distributed across two processors on a multiprocessor machine.

    When multithreaded processing is used for redraw operations (value 2 or 3), the order of objects specified with the DRAWORDER command is not guaranteed to be preserved for display but is preserved for plotting.

    -Joe

  • Note that the large sized words above are just an accident of the Markdown language.

    -joe

  • Given the specs on of the OP's computer I doubt the setting for VIEWRES or WHIPARC would have any affect. Now if he were using an old 386 or 486 Pentium with 512KB RAM then yeah maybe.

  • Wantseeyou,

    Do you experience this problem in all files, or just some .dwgs?
    If you start from scratch in a simple drawing, does the problem persist?
    Will you share the drawing that is causing a problem for you?

    Thanks,

    -Don

  • Thanks to everyone

    No other site gave me an answer.

    Thank you very much.

    Viewres = 5
    Whipthread = 3
    Whiparc = 0
    zoom factor=60

    There is no response to changing the variable.

    Rtzoom is very smooth. However, the mouse wheel does not.

    Attached file

    At zoom in / out, the object of the mouse point has become smaller, but other objects are delayed (0.2 to 0.5 seconds).

    Are you a graphics driver issue? The graphics card driver is the latest version.

    AutoCAD, gw cad is no problem.

    Thank you.

    zoom.png
    3840 x 2160 - 164K
    zoom.png 163.6K
  • When you are asked to attach a file in most cases we are expecting an actual .dwg file not a .png or .jpg as both of those formats are image files not vector files.

  • edited June 2017

    .

  • I don't know if it has anything to do with this, but if it's a logitech device the software has an 'Automatic Game Detection' button which affects the device behavior/speed in bricscad. It's best set to off.

  • Was this ever resolved? I am interested because I'm looking to get a laptop with the 1060 as well.

  • this issue is really easy to fix in Windows 10.

    Open the Start Menu, type mouse, and select the option that opens the Mouse & Touchpad Settings.

    In the Mouse & Touchpad Settings, scroll all the way to the bottom and click on the link labeled Additional Mouse Options. This opens a window that you might be familiar with from previous versions of Windows.

    Go to the Wheel tab and change the number under Vertical Scrolling. A lower number is slower scrolling while a higher number is faster scrolling. I like mine at 3, which is the default, but feel free to set it to whatever you prefer.

    I have used a XP-Pen star 06 Wireless Painting tablet for over a 2 years. I cannot (or will not use a mouse) due to repetitive stress issues. A pen is more natural for me to use. I use it for all my programs including BricsCAD.

    I can pick and choose objects, draw, enter coordinates with my left hand on the keyboard, zoom in & out with the built in wheel with my left hand, can issue commands and snap options with the buttons on the pen. I spend 20+ hours a week using BricsCAD. All the XP-Pen Deco Pro Tablet buttons are program specific programmable so it will work the way I want it to.

  • If this is happening in 3D try turning off DUCS

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam