Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Selection Problems

I have problems with Entity Selection by LMB Click in latest V17 Mac.
Wacom Cintiq 27 QHD Pen Display - Pen Input)

It mostly only highlights Elements.
It very often selects a whole bunch of Entities in shaded Views.

Instead I have to wait until the Quad opens and press LMB for about a second to make a real selection.

Do I have any wrong settings (highlight settings ?)

Comments

  • It works ok now by setting the pen recognition to "hard"
    in latest OS X versions of Brickscad.
    (just the file tabs closing icon cross that does not read my clicks)
    Selection works now reasonably well.

    But on latest Windows version I am doing very hard,
    when Face Selection Mode active (and using Wireframe View Mode),
    to get a standard entity selection by pressing STRG/CTRL.
    (I think that worked well on Mac)
    Where do I exactly need to hover my cursor ?

    I wished there would be an option,
    to select an entity first + subobject selections needing an additional
    key+click combination.
    Or that, when a Face selected, hovering over another element's Face
    can be also recognized as "entity selection", to allow tools like Connect
    to appear in Quad and operate nevertheless.
    Currently I need to manually switch Selection Mode very often.

    Also when you TAB through to finally select a hidden Face,
    and need the select coplanar faces Tool after,
    it should restrict a following e.g. BIM DRAG tool to that selection,
    which currently needs that complicated Face Selection done again
    to manipulate the correct Faces.

  • edited December 2017

    2.
    I confirm the SELECTIONMODES issue you describe. This is a bug. The problem does not exist in the last V16 version. Control-Clicking the center of a face should select the solid in your scenario. The current visual style should be irrelevant. You should send in a support request. Maybe switching to the X-Ray visual style can be a workaround.
    3.
    For the _BimConnect command selecting two faces will also work (tested on V16). So in some cases the issue is only related to the context sensitivity of the Quad. You can try changing the 'Entity Filter' of Quad buttons via the _Customize command.
    4.
    You can reselect (sub)entities by using the _Previous selection option.

  • Well, it seems to work quite well when Bricscad was opened and
    get worse over time.
    And it seems to depend on clicking before Quad opens (=good),
    while Quad opens and gets ready (= not good) and after (= ok)

    And it seems like it needs just 2 clicks (one to awake ?) in Standard Mode.
    (1. hover to highlight 2. CTRL+click to select entity 3. CTRL click to select
    sub object)
    then I can even do it in the different direction like standard mode
    + CTRL lets my select faces or edges (but not select boundaries)
    When Boundaries activated, these are available by just hovering though.

    And most important, it needs a "loooong" click to work more reliable.
    (long means until the 3D Gizmo appears)

    Currently I'm still often not sure if it's a bug or I'm just using it wrong.

    1. does definitely not work here.
      If I have Face Mode, things like Connect will not appear in Quad,
      if I am in Standard Mode, tools like BIM Drag are hidden.
      (It will work when I finally have CTRL selected something)
      Would be nice if pressing CTRL key itself while hovering would switch
      modes.

    4.
    That _Previous is not recognized (?)

    I currently use latest v18 on Windows.

  • edited December 2017

    2.
    I am convinced that this is a bug related to the 2dWireframe visual style. It has probably escaped notice because few 3D modelers use that style. If you prefer this style I suggest you set SELECTIONMODES to 3 (or 7). Control+Click when hovering over an edge will then select the whole solid.
    4.
    _Previous is not a command. You can use this keyword whenever the program prompts for a selection. There is a 'Select Previous' tool however but it does not work properly.
    My suggestion:
    In the right panel of the _Customize dialog expand the 'Select' node and select the 'Select Previous' tool.
    Change the command to:
    ^p$M=$(if,$(getvar,cmdactive),_p;,_selgrips;_p;;)^p
    And add a keyboard shortcut for this tool. I have used:
    Ctrl+Shift+A

  • I use Wireframe.
    2D Wireframe behaves differently.
    But as Wireframe will also select Faces of front elements, you can’t
    use it like other Apps Wireframe modes anyway.
    So I went back to BIM and added 10% transparency.

    And I think, since I accepted that there are 2 clicks needed and I got
    used to it, it works quite well and predictable for me.

    I also lowered time for Quad appearance, which took some more lag
    out of my flow.

  • edited January 1

    The Wireframe visual style has the same problem as 2dWireframe visual style.

    And you do not have to pre-select the solid to select one of its sub-entitites. In my tests with the BIM visual style (but the style really should not matter) a single click or a single Control-click is enough to select a solid, a face or an edge. And if you are working with the Quad you do not even have to click on the last (sub-)entity that you want to work on. Just (Control) hover and then move the cursor over the Quad and click a button, that is enough.

    BTW: I have tested with V18.1.09 on Windows 8.1.

  • At least when fresh opened, it works as you describe.
    A few seconds later I need hover+ALTclick+ALTclick

    But I can't select 2 entities by ALT Mode, like I need for connect.
    I need to select these with the marquee (if ever possible).

  • Mind that on OSX, control is not a proper modifier to use in combination with clicking, since control+click is an alternative for right-click. So a plain click is not possible on OSX while control is being pressed.
    Therefore, in BricsCAD(Mac) V17, when using control to highlight an entity at mouse position, it is not possible to click the highlighted entity to select it.
    This is a known issue, but we realized it too late. When we noticed it, it was considered too far-reaching for fixing in V17.
    To act on the highlighted entities you can instead keep holding control, move into the quad, then release control, then click on a quad button.

    In the upcoming BricsCAD(Mac) V18, the command modifier (Apple key) is to be used instead of control (which is really the usual windows-osx modifier translation). Accordingly pan by command+mouse move has changed to pan by control+mouse move.

    I am not sure this will help with the Wacom pen input, but it does seem quite related to this thread.

  • Thanks Tijs,
    Currently I am on my holiday OSX 10.7.5 machine, so only Bricscad
    V18 on Windows by Parallels VM.
    So this is my current Windows behavior. But my MS IntelliMouse with
    its OSX driver is transferred over Parallels as a virtual HID mouse in
    Windows. Maybe Bricscad does not really like it, if it works for Roy.

    Yes, V17 OSX had some problems with CTRL clicks.
    I also heard that V18 OSX will change that :)
    I was still not able, on any OS or Version, to get the key combination
    for Zoom (when no scroll wheel available ) as described in settings
    though. Maybe also a Parallels thing.
    (mapping some shortcuts to Windows by "CMD" for Mac users)

    But I'm back on my current nMac Pro soon.

  • Hello Roy,
    (by design) the selection behavior is different for the 2dWireframe & Wireframe styles versus the other visual styles.

    Using a wireframe visual style, with SELECTIONMODES = 0, a 3dsolid will only highlight when one of its edges is hovered or selected, nothing will happen when hovering its faces.
    The Ctrl key allows to invert the current selection mode and as such temporarily enables selection of faces or edges.

    Using a wireframe visual style, with SELECTIONMODES = 2 will give selection priority to faces and pressing Ctrl will invert the selection mode and revert to the behavior as if SELECTIONMODES = 0, that is: only select or highlight the 3dSolid when one of its edges is hovered.

    We indeed changed this in V17 because the V16 behavior was inconsistent, and added undesired code complexity and regression risk during maintenance.

  • @Hans De Backer:
    Thank you very much for your explanation. Strangely this important change is not mentioned in the V17 Release Notes.
    You description is not completely accurate:
    When SELECTIONMODES = 2 it is impossible to select the whole solid with a single (Control) click.

  • @Roy said:

    Your description is not completely accurate:
    When SELECTIONMODES = 2 it is impossible to select the whole solid with a single (Control) click.

    You're right Roy, only when SELECTIONMODES = 3 and clicking an edge, the Ctrl-inversion will result in selection of the entire solid.

    We found that when wireframe visual style is used, it is debatable which decision should be taken when SelectionModes = 2 and Ctrl is pressed while hovering an edge: select the edge or select the entire solid? To keep the selection behavior differences minimal between working with wireframe and non-wireframe styles, we opted to also select the edge.

    Given that wireframe is not often used for modeling, we hope this is not too big an issue.

  • @Roy Klein Gebbinck said:

    >

    When SELECTIONMODES = 2 it is impossible to select the whole solid with a single (Control) click.

    Same experience here in Wireframe.
    (I don't get any Entity Selection when in SELECTIONMODES = 2, just edges)

    (BTW what is the difference between 2D WF and WF mode ?)

    Generally a CTRL or STRG Click has never all features that the correct
    Sub Selection Mode offers (TAB). It may work for your first element
    selection but you'll be stuck when needing a second (sub)element.
    That is why I constantly need to switch in my Selection Mode Palette.

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam