Cursor/Crosshair corrupt

I assume it would be time again to replace my config but want to avoid that if possible.

Instead of a Cursor or Crosshair I have now an about 100x100 Pixel black square.
It diminishes while I draw a Marquee Selection but reappears immediately at any time
else like drawing or just hovering over my View.
It is not over dialogs, just in my View Window, no matter if Model 2D/3D, Shaded or not
or in Layout. It is in my active V18, V17 is ok.

As my preferred Full Screen Cursor did never work on Mac, I usually have cursor size to
3 only. As the cursor would disappear when I set 100.
When I play with the value, everything more than 10 makes my black square disappear,
but that is likely the limit above any cursor disappears on Mac.

I tried all settings that I find but has anyone an idea which setting could be wrong ?

Comments

  • CROSSHAIRDRAW all OFF brought it back.
    A few seconds before I noticed that the Cursor was somehow there but stuck
    at the left top corner of my View Window.

    Render Crosshair by RedSDK for 3D > is "not allowed" !

    (While Render Crosshair by OpenGL for 2D leaves no rests of traces for me
    but made the RedSDK crash somehow anyway)

  • Michael,
    I'm using Mac V18, and have my crosshairs set to 100. No problems with that, although I do have problems with my cursor randomly disappearing when I have an activity window open (like insert block or pdf). Sometimes it disappears when in the window, sometimes when over the drawing view. I have a support request in on this issue, but no resolution since February.

  • Michael Mayer
    edited April 2018

    Hi Jeff,
    that is interesting. I was never ever able to get my cursor full screen
    since the first Bricscad Mac Version (V14 ?) that I tested.
    A minute ago I tested all CROSSHAIRDRAW options and tried again to set
    cursor size to 100.
    It seems to work in 2D only views, if one can live without a cursor in 3D :smile:

    But I think switching between 2D and 3D a few times with :
    size 100, OpenGL 2D ON, RedSDK 3D OFF,
    was what finally crashed graphic acceleration.

    Are you working in 3D ?
    And could you tell which Bricscad STD/PRO/BIM and Mac Model you are
    running, please ?

  • I've got standard V18, but haven't worked in 3D. I'm using a 2015 iMac with 16 GB ram, AMD Radeon R9 M390 2GB, OSX 10.13.1
    One other crosshair problem I have is when I change the snap angle (ie: rotate the crosshairs), I get crosshair ghosting as I move around the window that only goes away when I switch between open drawings. No support solution on this one for a couple years.

  • Thanks.
    So no special Mac with NVidia GPU or something like that.
    AMD too here.

    You could try CROSSHAIRDRAW OpenGL for 2D = ON
    if it wasn't already. Without I had also some ghosting rests without.

    It was just that I ran through Settings for something else and wasn't aware
    that there are 2 of these Redway Settings. And as far as I remember I need
    the general GPU accelleration by RedSDK =ON, so I "reactivated" it at the
    wrong place accidentally.

  • thanks for the CROSSHAIRDRAW tip. Seems to work so far. Funny, support never suggested trying that switch.

  • But try to not forget that setting,
    in case you run into problems at a later time.

  • V19 Mac

    Crosshair Cursor can be set to REDGL,
    it won't appear when crosshair size 100 though.
    All values above 10 will show no cursor in views at all.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!