Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Hide Entities when exporting & publishing to PDF

Would somebody else mind checking if it is me or Bricscad.

If I create a layout and export as PDF; objects I have hidden using hide entities aren't printed.

If I Publish the same layout, the objects aren't hidden!

I am using V17.2.06

Many Thanks in advance & sorry if this already a known issue.

Comments

  • Works correctly for me (V18). In the second PDF the cone is "hidden" from model space. Both were created via "Publish."

    Could be a setting issue, somewhere? Try starting with a new, default user profile and clean template.

    pdf
    pdf
    example.pdf
    120K
    pdf
    pdf
    example-hidden.pdf
    30K
    dwg
    dwg
    example.dwg
    20K
  • Richard,

    Apologies for the late reply, I haven't had the chance to play around with this.

    I tried a new profile with default-mm template and get exactly the same result, everything is visible.

    Do you or anybody else have any idea what setting (if there is one) I need to change to get this to work?

    I find it strange that it works ok with export pdf but not publish pdf.

    Thanks for the help.

  • Hi David,

    In PUBLISH try turning off (uncheck) the option to print in the background.

    Regards,
    Jason Bourhill
    CAD Concepts

  • Hi Jason,

    Thanks for this, it works perfectly now.

    Is this setting deliberate or should I raise a support ticket?

    How do I mark this as answered?

    Thanks again I would never have made the connection.

  • @Jason Bourhill said:
    Hi David,

    In PUBLISH try turning off (uncheck) the option to print in the background.

    Regards,
    Jason Bourhill
    CAD Concepts

    Interesting! I recently switched off "print in background" -- it seems to publish to PDF faster in non-background mode, even when grabbing paperspace sheets from a dozen different DWG files, so I've left it like that. Wonder why the difference in behavior?

  • edited May 25

    Hi David,

    thanks for offering to report this V17 issue with background publishing. FYI, meanwhile it has been fixed in V18.

    Hi Richard,

    one reason that publishing in the background is slower, is that it requires creating temporary copies of all files that are involved in the publish session. This is done to ensure that the version of the published drawings exactly matches the one as it existed at the start of the publish session, instead of a meanwhile already newer version. In these temporary copies, all paths to e.g. xref and other attachments have to be modified so they point to the location of the temporary copies of these files...

    Another reason is that an additional BricsCAD session has to be launched to perform this background publishing.

    Background publishing wasn't introduced to speed up the publishing, it was introduced to allow users to continue their drawing activity without having to wait till the publishing is completed ;-)

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam