Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Z not = 0

Working in a new file in 2D straight after 19.2.03 install, entities are getting a Z value on creation - esp Xlines - and it's getting worse. Is there a setting to force z=0?

Flatten explodes my Blocks, or rather gives them new unique names.

Comments

  • Did you check the Elevation setting yet?

  • My guess is that there are some snap points in the dwg with a non-zero Z and xlines that have been created from those points have a small incline leading to a greater delta Z as you move further from their first point.

  • Louis, this is 3D>Elevation? It's 0.
    Is this the only setting which guarantees z=0 in 2D drafting? which in turn depends on the Current UCS (if any) being exactly 0,0,0.

    Roy, yes I think that's why Xlines show huge z, like 120000, while say a Line shows only z=0.015. Often, when deleting and re-making an Xline from same point, it would be fine, z=0.

    Well, it seems to have stopped now, after overnight close/re-open (yesterday, close/re-open didn't help).

  • @Tom Foster said:
    Is this the only setting which guarantees z=0 in 2D drafting? which in turn depends on the Current UCS (if any) being exactly 0,0,0.

    Yes that's correct. But, if you snap to a point which is not at z=0, the entity being created does not lie in the XY-plane; e.g. when defining the first point of a polyline, the polyline lies in a plane parallel to the XY-plane at a z value of the snapped point.
    When you think there is something wrong with your drawing, please file a support request.

  • Yeah OK. Thanks

  • Also set osnapz to on (ignore entity snap elevation)

  • Good - thanks

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam