Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

not all panels are enabled when setting a AcadApplication visible

I create an AcacApplication by COM,
acAppComObj = (AcadApplication)Activator.CreateInstance(Type.GetTypeFromProgID(strProgId), true);
then I open an existing drawing (with sheet metal part that is smconverted)
acAppComObj .Documents.Open(povDwgFile);
and set the application visible.
acAppComObj .Visible = true;

But the Mechanical browser often stays disabled (see attached screenshot) . Am I doing something wrong or should I call some specific refresh?

I'm using BricsCAD V19.2 now.

panel disabled.png
3840 x 2100 - 293K

Comments

  • edited March 15

    For your info,
    I managed to get the panels activated when I call folowing line after setting the app visible:
    acAppComObj .RunCommand("_redrawall");

    But nevertheless this should not be needed in my opinion.

  • Try changing the Active property of the dwg to true.

  • Thanks for this solution, Roy. Thats exactly the case i got while displaying OpenDCL panels.
    The activate property of the current document will fix this issue.

    Martin

  • @Martin Drese
    Thanks for confirming this can be effective.

    Pity @KarelVergauwe can't be bothered to respond.

  • Sorry,
    did not find the time to reflect on this.

    I tried both ActiveDocument.Activate() and ActiveDocument.Active = true but it did not enable the panel.

    I stick with the _redrawall lisp for now.

    What I did found out was that any lisp / command activates the panel

  • @KarelVergauwe
    Thanks for getting back to us and sharing your findings. It may be worth sending in a Support Request regarding this issue.

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam