Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Problem getting my v14 fresh install to start a new drawing

I have a new computer, and had to do a fresh install of BricsCAD v14. However, I have yet to successfully get it to allow me to start a new drawing.

  1. I can open existing drawings.
  2. I can not open a new drawing from the qnew command, nor from File/New and browsing to my templates.
  3. If I choose File/New, then the file browser opens to the correct directory where my templates are stored, but it does not start a drawing.
  4. If I try the NewWizard and choose "start from scratch" BricsCAD crashes.

My templates are on a separate drive from the Bricsys folder, but the path to them is correct in the default template path, and the templates directory path. But, selecting one of them and pressing OK, does not result in a new drawing. There are no errors on the command prompt history either. Here is the entire content of the command prompt history.

;
;

_new

Because my on_doc_load.lisp has some stuff in it, I disabled it by renaming the extension, but that did not change the behavior at all.

Any other ideas to try?

-Joe

Comments

  • Also, are there any ways to disable the message formatting? I often have problems with this, and the above message is a good example. And I didn't even try to format any code this time (a sure fire way to get the message formatting messed-up).

    -Joe

  • I would first try using one of the dwgs you can open as a template. If that works your problem is probably OS related. Perhaps you do not have sufficient permissions for the template folder?

  • If I use the File/New command, it opens in the template directory that I have in the template file path of my settings. I can change the file type to show .DWG files. But, when I select and open that, I get the same behavior as before.

    I just noticed that in my 1st post, I said that only the _new command shows on the command prompt. But, now I see that BricsCAD does run the on_doc_load.lisp when I attempt to start a new drawing, as evidenced by some text that the on_doc_load.lsp prints on the command prompt history. But, like all the other attempts, no new drawing is actually created. Note that this running of the on_doc_load.lsp file is only occuring if I try to start a new drawing and already have another drawing open. If I start with no documents open, then the attempt to start a new drawing is as I reported in my first post, showing only the the _new command.

    Regarding permissions. I did a test by using the File/New command, and then browsing to the template directory that in the default BricsCAD directory, where it is placed when BricsCAD is installed. I get the very same behavior as above. So, I don't think the alternative template directory is an issue.

    -Joe

  • edited June 24

    If I use the File/New command, it opens in the template directory that I have in the template file path of my settings.

    That may have changed in later versions.
    But I can't remember ever(*) being asked "which" Template to use when I choose "New File"
    It will always just open a new file without any option and use the Template I opted for in Welcome Dialog.

    (* AFAIK I started testing Bricscad with v14 ?)

    Did the Welcome Dialog come at later Versions for the first time,
    or have you deactivated it ?

    There is also the "New Wizard" in recent versions,
    that gives all kind of options, like selecting any kind of template and such.

    If I try the NewWizard and choose "start from scratch" BricsCAD crashes.

    Somehow that sounds to me like the your Template files being corrupt or
    from a newer File Version of Bricscad (?)
    Maybe you could try to hide your Folders containing Template Files by renaming,
    to force Bricscad to create new default Templates ?

  • edited June 24

    I have finally honed in on the trigger. If I disable the on_start.lsp file (by renaming the extension) everything works fine when I start a new drawing. 1st, thank you for all the comments. It helped me to be confident that I had checked the right places. And it now works even when I have BricsCAD set to go to my personal template directory on another drive.

    The on_start.lsp file has the following commands, which will automatically close the blank drawing that is created upon startup.

    ; this file will run once when the program starts.
    ; The code below is to automatically delete the blank
    ; drawing that BricsCAD creates when it opens.
    (if (zerop (getvar "dwgtitled"))
    (progn
    (setvar "cmdecho" 0)
    (command "_.close")
    )
    )

    This was the only way to not have a blank drawing that I need to manually delete. There is no setting to prevent it. There was no problem with the lisp before. And even the paths and directory structure between the old vs. new, is identical.
    Here is all the code.

    I am guessing that something in the Windows 10 security settings is stopping this from working. I always run BricCAD "as administrator" because if I don't then I can't get my settings to save, and I can't get other programs, like Excel, to work with BricsCAD. Any clue about how to make it work again?

    -Joe

  • Maybe there is a setting in Bricscad that will always start
    with a blank file when you open it.
    Like Vectorworks has an option, which I never activate.
    In Bricscad, when I start with New File in welcome panel,
    it will open with just one empty file created from my
    default template.
    But I think that works as intended.

    When I start Bricscad by double clicking a file in Explorer or
    Open other File in welcome manager,
    it will open with that specific file only, for me.
    No extra blank file.

  • It could be that on_start.lsp is run whenever you open a (new) drawing. The ACADLSPASDOC setting controls this behavior.

  • It sounds like you haven't used BASEFILE to set a default template. Your LISP relies on BricsCAD starting using a default template, which it then closes.

    I would also check that you have set STARTUP = 0. If it's set to = 1 you will prompted with a dialogue.

    Regards,
    Jason Bourhill
    CAD Concepts

  • @Roy Klein Gebbinck said:
    It could be that on_start.lsp is run whenever you open a (new) drawing. The ACADLSPASDOC setting controls this behavior.

    Roy wins the prize, with Jason as the runner-up.

    I had assumed that transferring the user profile would have brought these settings over. But, perhaps not that one.

    Thank you to all who helped track down this issue.

    -Joe

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam