Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Ongoing problems with LISP that creates fields

I have had this ongoing problem with trying to use LISP routines that will call out the length of a polyline. Most recently, I've tried one by Lee Mac, and his programs are all well done, so I assume the problem is something at my end.

Specifically, I am trying his LengthAreaFieldV1-3.lsp utility, which prompts the user to select an object(s) and then a text (or other similar) entity which is changed to show the length of the objects you chose with a field. [ http://www.lee-mac.com/lengthfield.html ]

In my case, I tried it on a polyline, and then the text of a leader I had created with the word "length". [Edit... I see now that my choice of the text "length" was not a wise one, since the phrase ".length" is how such a field should normally end, since it calls out the length. If I had used "test", the word "test" would simply have been replaced. ]

The results are below. Note that it is this code that shows, not the actual length.

%%).Length

Similar utilities from other sources generate similar results. Any ideas what the problem might be?

-Joe

Comments

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam