Trouble with correct scaling in a viewport within a layout

Being admittedly new to trying to use layouts (paper space) instead of printing from model space, I find it to be confusing on how to: 1. Draw with appropriate units in model space (this is easy), then 2. Create a layout with a viewport that fits the printable area and has a simple 1:1 scaling, e.g. when printing, a 1" part is 1" long when printed. The same applies to smaller viewports ... and still desiring a correctly scaled print (1:1 or whatever). The learning and tutorial stuff online really doesn't address this very well.

I did figure out how to create a new layout, then add a viewport (with 'fit'), and tried associating the layout with a 1:1 scaled page setup ... but the scale was waaaaay off in the viewport?

Brian

Comments

  • Anthony Apostolaros
    edited January 2020

    I'm not sure I understand the question, but after creating a viewport you have to assign a scale to it. The Fit option of the Mview command creates a viewport that fills the current Layout tab and shows everything that's in Model space, at whatever scale it takes to do that.

    You can set the scale by selecting the viewport and changing the Misc > Standard scale line in the Properties panel. If the scale you want isn't in the pull-down list, you can instead use the Misc > Custom scale line.

    After setting the scale, you should lock the viewport immediately, using the Misc > Display locked line of the Properties panel. Do that so that you won't accidentally change the scale later while inside the viewport.

    The older method of setting viewport scale is to go into the viewport and use the Scale option of the Zoom command. And you can lock a viewport with the Lock option of the Vports command.

  • Anthony ... thanks. I think I did as you describe, but perhaps not. I will take another look tonight and if it's not working, then will provide step by step on what I did and screen captures to show the results. If it works well, as you'd expect, I will post my success here as well.

    Brian

  • Recently, when a Vierwport perimeter is selected in Paperspace, on the Status Bar at the bottom Brics can now display a VPLOCK button, which is the easiest way to lock/unlock the Viewport.

  • Thanks, Tom. Sometimes, and I'm not sure of the workflow that does it, but when adding/removing viewports and changing scaling, the dashed-line perimeter of the printable area disappears (v20). I haven't mentioned it yet because I need to rediscover the steps for reproducing it.

  • At the bottom of the working area, tabs Model, Layout 1, Layout 2 etc (until you rename the Layouts) - R click on the highlighted tab, click Page Setup. At top left select Printer configuration - hopefully all the printers you have installed, also things like CutePDF that you can 'print' to, will be present. The dashed line varies depending on which printer you select - even disappears if you select Fax, maybe others.

  • OK ... the only 'printers' that I tried are the Print to PDF and my Canon (ANSI B) printer. I'll experiment tonight when I'm back in the shop...

  • That's ANSI B that is.

  • @IdahoDixon said:
    .....Sometimes, ... when adding/removing viewports and changing scaling, the dashed-line perimeter of the printable area disappears ....

    When you make a viewport that's the same size as the printable area, the edges of the viewport then cover up the dashed line perimeter of the printable area. It's still there, but it's covered up.

    Another way to show the printable area perimeter is with a change in background color, which you can get by checking the "Display paper background" box in the Settings panel. Then you'll be able to see the printable area perimeter even if there's a viewport or rectangle over it.

  • Ah .... I suspect that's where the dashed line went. Thanks for the hints....

  • OK ... The s/w works as it should. My level of understanding was a bit off. BUT that said, I have no clue why page setups always seem to have 'center on page' disabled, unselectable ... and I'm confused about the annotation scale under Misc when the viewport is selected. My learning continues....

  • Anthony Apostolaros
    edited January 2020

    @IdahoDixon said:
    ... I have no clue why page setups always seem to have 'center on page' disabled, unselectable ... and I'm confused about the annotation scale under Misc when the viewport is selected ...

    The 'center on page' option is disabled when Plot Area = Layout. The drawing area to be printed completely fills the printer page. It can't be anything other than centered.

    I always use Plot Area = Layout. But if you need one of the other Plot Area methods, you can choose it and then the 'center on page' option should become available.

    I never use annotation scales, so I can't help with that.

  • Thanks, Anthony...

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!