Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Couldn't update section

I tried to follow the guided BIM lesson 05 about using the Project Browser without success. I created a new project as instructed. Then, when I right clicked on a section in the project tree and chose "Update", the command prompt displayed, "Couldn't update section", and no section was generated.

Next, I right clicked on the Project Browser panel, selected "Sheetset Setup", and this familiar box appears:

When I clicked OK a Sheetset Setup dialog opened but all the fields were blank. I restarted BricsCAD and hit the same roadblock again.

This is happening with the dwg provided in the tutorial (Exercise 5 starter file.dwg) as well as with a new dwg based on Default-imperial template.

I think this is related to ongoing sheetset issues, perhaps?

image.png
517 x 140 - 4K

Answers

  • I made some progress on this exercise, but still fail to follow the steps smoothly:

    With project browser's Sheetset Setup triggering unexpected errors as described above, I manually created a new empty sheetset ("proj_5.dst") from the sheet sets panel. Saved it in the same folder as my BIM dwg file. In the BIM dwg, I set "projectname" = "proj_5".

    Right-clicking in the project browser tree to "update" (i.e., generate) a section still failed. Instead, I selected the section in the structure tree and used BimSectionUpdate, which I've had success doing previously. However, this attempt also failed to generate a section drawing, and gave an error that the sheet template file was not found. I checked the path listed in the sheet set Sheet Creation properties and saw that it was pointing to the project folder containing the model file. I tried to redirect it to the templates folder, and it seemed to accept my entry. Yet, I got the same failure again with BimSectionUpdate, which continued to insist on searching back in the project folder for the sheet template.

    To finally get BimSectionUpdate to cooperate, I had to make a copy of the Sheet-mm.dwt template file into the project folder. Then I was able to generate all the sections. And now that the drawing sheets have been created, I am finally able to right click "update" from the project browser tree as in the tutorial.

    I must have modified a setting incorrectly somewhere, or am missing something. Any thoughts?

  • Continuing to chronicle my efforts to tame the BricsCAD BIM beast, I am happy to report more progress (if anyone is listening):

    Project Browser and BimSections are playing nicer, although sheet sets are still misbehaving.

    One change I made was to add the path to our custom (imperial) sheet template folder to SRCHPATH as well as to SheetSetTemplatePath. I thought it had been listed in both, but at some point, maybe on installing a recent version, it was in the latter only. Odd that that should cause trouble for the Exercise 5 starter file, which I downloaded from https://lessons.bricsys.com/courses/613627/lectures/10984497 and which uses default metric templates. I did not have to change SheetSetTemplatePath back to the default; merely adding that location to SRCHPATH seems to have gotten me back in business with the starter file, as well as with fresh models in new test projects that I've tried so far.

    Now, wonderfully, the BIM tools to generate drawings are working—both BimSectionUpdate and the right-click-in-Project-Browser "update" procedures—without errors about not finding the sheet template.

    One of the things that happens properly now, which didn't before (and is not in the guided lesson), is that clicking OK on initial Project Setup automatically opens Sheetset Setup. That is the dialog I had been trying to access when I got the unexpected errors shown in my original post. I am befuddled how to modify which section goes on which sheet, and how to finesse the placement of drawing views from within Project Browser, but at least I have the default functionality working, and it really is amazing!

    I mentioned, however, that sheet sets continue to misbehave. Two major problems:
    1. the previously-reported, seemingly-random error "Unable to locate sheetset file: ..." is still happening occasionally, especially (but not always) upon saving a sheet .dwg file:, and
    2. missing custom sheet properties for sheets generated via Project Browser. [I will post a new question and support request about this one soon.]

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam