Shademode and light changes in V21 (SOLVED)

CAR
CAR
edited November 2020 in 3D Modeling

Hi all
Problem: Latest V21 has considerable changes regarding light, reflections, etc.
The change is documented on the "What's new" text. So didn't caught me totally by surprise!
Regardless the issue remain. Because I do have all my work done with previous versions like V18, etc.
Until V20 there was a few head ache's, as not everything was shown the same way, see fittings in following images. But it's still acceptable, at least to a point I can live with.
But the latest V21 the changes are simply too much...

Question: How can I revert V21 shademode settings, to the parameters used on V18?

Note: Importing .ARG file produced no effect.
Saved views, produced no effect.
All three images are showing "gouraud" shademode.

Below are screenshots from, exactly, the same assembly on V18, V20 and V21 with similar point of view and zoom.
The ideal "standard" for me would be how its shown in V18. I surely don't want to mess with these files.
On V19 and V20 there's some not desired changes, but livable with.
On V21 it's a disaster...

Cheers


Comments

  • Michael Mayer
    edited November 2020

    All three images are showing "gouraud" shademode.

    I am not really sure if your images are standard 3D Viewports or "rendered" views.
    And I did not find where I could switch to "gouraud" shademode.
    Neither in Materials, Visual Styles nor Render Presets.

    If it is about a Visual Style, like "Shaded",
    these have a Color Setting. "Normal" by default,
    but could be accidentally set to "Desaturate".
    (That is how the V21 image looks to me)

    EDIT :
    Looks like the "Color" Setting doesn't work, or better, is overwritten
    by "Material display" setting.
    If it is set to any other than OFF, Entity/Layer Colors will look desaturated.

    Because the "Global" Material will occlude the Entity Color.
    If you don't use Render Materials, all entities will use "Global"
    And it Looks like V21 "Global" Diffuse Color is set to White.
    If you change Diffuse by activating "inherit",
    all Entities with Global Material will use their Entity or Layer Color instead.
    This way they don't look "desaturated" anymore.

    TL;DR;

    You could either deactivate "Material Display" setting in your Visual Style
    or
    activate "inherit" for Diffuse Color in (the Global) Material(s)
    to get your saturated Colors back.

  • CAR
    CAR
    edited November 2020

    Hi Michael
    Thank you for participation. Those are "run of the mill" views. All are set to the same "shademode", which as mentioned is "gouraud".
    In the ones attached now and to avoid further confusions, both are set inclusive to the same black background.
    Once more it's exactly the same file, opened simultaneously in V18 and V21! Of course for that reason, one of them is opened as "read only".

    "And I did not find where I could switch to "gouraud" shademode.
    Neither in Materials, Visual Styles nor Render Presets."

    There's no obvious icon to click for "gouraud" shademode. Or gouraud with edges, etc.
    The following command prompt sequence will take you there:
    Shademode>Other>Gouraud or GouraudWithEdges, etc.

    BTW it's not material display and such.
    Upon installation of V21, it's quite explicit in the "what's new" that they lighten up the regular display

    !

    Point in this case is, can I find the regular settings of V18 and transport/import/transfer to V21?
    Notice that nothing is specially tuned on the V18 or the V21, for that matter.
    It's totally OEM or virgin installation if you will. ;-)
    Thanks and Cheers

    Edit: For what it's worth under visual styles you won't find gouraud or any other option either!
    BUT if your try to create a visual style called "gouraud" or any other already existing. The error message will explicitly say it already exist!

  • Yes, I think I got it.
    Gourand is just another Visual Style, just like default delivered, BIM, Realistic, Shaded, ...
    They are also saved in the File (?)

    Either Bricscad renamed the old Gourand Shade Modes to "Shaded (w/o Lines)" or
    these are updated Modes.
    There are not all Modes visible or accessible in Drawing Explorer, Command Line seems
    to have a few legacy Styles more. But no Gourand to find for me !

    That is not a problem. As Bricscad BIM has e.g. no "Shape" Visual Style to choose,
    which is used in Bricscad Shape by default.
    But if you open a DWG from Shape in Bricscad, that file will offer the Shape Style in
    Bricscad now.

    So I am sure your legacy Gourand Visual Styles come with the file into Bricscad V21.
    As it is in your File and in use, you should also find that Style in Drawing Explorer,
    where you can check and adapt its settings.

    All Visual Styles should basically have all the same options.
    But it looks like for UI reasons, simpler Modes like Shaded show less settings than
    more complex Styles. To make them simpler to use. So e.g. Shaded has no Material
    Setting - as it is not meant to use any.
    But maybe there went something wrong in migration or similar.

    So please try, in Drawing Explorer
    if your Style has a Setting to show Materials or Materials and Textures, switch it off.
    If it hasn't, go to Materials, activate "Global", Diffuse Color (on top) and activate "inherent"

    Either of these or both changes together, should bring your strong colors back.

  • CAR
    CAR
    edited November 2020

    Hi Michael
    To clarify, all the visual styles are usable in all versions independently of being "visible" or not.
    Material is not an issue, since we're talking about the same file without any materials associated.
    In the following example, comparison of V18, V19, V20, V21.
    Solid created on V21, and opened on the other versions as read only. One is copy of the other,only with different colors "bylayer", 1 is color 30, the other color 102, totally random choice. No materials, light settings or anything else changed.
    Simply open on different versions with the results that can be seen on the images.

    I'm not sure if you saw this edit of my previous msg.
    "Edit: For what it's worth under visual styles you won't find gouraud or any other option either!
    BUT if your try to create a visual style called "gouraud" or any other already existing. The error message will explicitly say it already exist!"

    BTW this is on drawing explorer! Maybe I haven't expressed successfully, but the main point. Is that they're ALL the same, same file, same (file) settings...
    The differences are solely between Bricscad versions since no settings or adjustments took place. Inclusive the file was opened simultaneously in all versions (read only). So it's not even a question of saving the file from different versions!

    As you said "All Visual Styles should basically have all the same options."
    Yes they should, but aparently they don't. At least between Bricscad versions there was an obvious change... which I'm trying to revert at user level!
    After all there's a couple of years of work and literaly thousands of components and parts, that regarding V21 visualization is totally "fubar"!

    For what it's worth, this is the only thing I found on the "Release notes" of V21:
    "3D Display
    Material glossiness has been adjusted to ensure that entity details are distinguishable, even with glossy materials. The glossy effect is less intense for light materials, and more intense for dark materials.
    SR90134 "

    V18 & V19 show exactly the same.
    On V20 it lighten up a bit and the background color also seems different.
    But the rather shocking change is on V21!




  • I am aware that you don't assign/care about special materials.

    Nevertheless I try it again,
    please test to switch on "Inherit" for Diffuse Color for Bricscad's default Material called "Global"
    and report if it helped or not.

  • FYI: there are 'for internal use only' visual styles in a DWG. "Gouraud" is one of them.
    To get some insight in the available styles type this in the Command Bar:

    (entget (dictobjname (namedobjdict) "ACAD_VISUALSTYLE"))
    

    To remove a visual style's 'internal use' flag, and make it visible in the Explorer, you can do this:

    (vle-entmod 291 (dictobjname (dictobjname (namedobjdict) "ACAD_VISUALSTYLE") "Gouraud") 0)
    

    Also look at the _-ShadeMode command, which has "Gouraud" options.

  • CAR
    CAR
    edited November 2020

    Hi all
    Sorry for late reply, but my professional obligations sometimes keep me away.

    Thank you all for the input, indeed very helpful and enlightning.
    I'm pleased to announce this thread will be marked as "solved". :)

    Michael: Yes, it helped. And I'll call it the "solution" for this case.
    Curiously might be some "release note" regarding this new default, but if such I haven't seen it!
    For the record, the same file doesn't present itself "exactly" the same way.
    There's still differences, but definitely I can live with it while I fine tune the rest. ;-)

    Roy: That's some awesome piece of information!

    Thank you guys, much appreciated. :)

    Edit:
    To document, with images. Here it goes.
    V18 as it was and as always been.
    V21 to reflect Michael sugestion.
    Cheers


  • Michael Mayer
    edited November 2020

    I am happy to hear that it also worked for you.

    I think "Inherit" was always on in previous Versions.
    That way the "Global" Material, that is set for any Layer's Material setting
    as default, for any Entity that is still set to default (by Layer) Material,
    will render the Entity with Layer (default) or Entity Color.

    Seems that has changed with V21.
    Inherit is OFF and Diffuse Color set explicitly set to White.
    So all Entities by default now render in White
    ..... wait .....
    Why do you see still a bit of Layer/Entity Color at all ?

    Because that (legacy) Ambient Color Setting,
    (which is meant to control a Color that Materials show when not lit by a light,
    so in shadow or lit by (legacy, fake) overall Ambient light)
    is set to "Inherit" by default now
    and will tint the Diffuse Color a bit, the more the Faces point away from any light.

    Therefore your migrated Models with previous settings look desaturated in V21 now.

  • @Roy:
    Thanks for continuing to enlighten us.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!