Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Mouse control

I've re-visited Bricscad a few times over the years - each time I like a lot but something always feels "off".

In particular, it always feels like I'm "fighting" with the mouse to get the cursor where I want it - whether it's direct positioning or activating the desired snap. Are there some customization settings that will make the cursor movement more "natural"?

Comments

  • Not sure this is what you are looking for.
    Is this a laptop?
    What is your Windows OS?
    What is your video card? Driver Update?
    What is the DWG file size? What kind of dwg are you opening? Is this a problem in ALL files or just one?
    Is it snapping to the grid? Using polar-tracking?
    I provided a screenshot of my settings from V21 if that helps.

    image.png
    1034 x 411 - 94K
  • It does happen to be a laptop - but I'm not using it in "laptop mode" - external keyboard/trackball/monitor. And I have the same issue on other PC's.

    Windows 10, nVidia GTX 980M, current version.

    The problem is with anything - even starting from scratch. It's not a performance issue - it's simply how the cursor moves on the screen and particularly how it interacts with the autosnap points. In...the other program...the mouse moves smoothly and activates the snap points as expected. But in Bricscad it always feels like a fight - I don't see the snap indicators appearing without being very finicky with the mouse positioning. It feels like there's a grid snap always active even though I thought I turned it off.

    So either I'm trying to use Bricscad in a manner in which it's not designed - which means indeed I am fighting against some convenience features I don't understand or haven't gotten comfortable with yet (like the Quad) - or the default settings for whatever reason don't match what I'm used to and there's some simple tweaks that will help.

  • I have the same issue and actually thought it was me (operator error/getting older) but it does seem like you have to be much more precise with your mouse to engage a snap point. Very frustrating.

  • The default setting of SNAPTYPE=2 is uncomfortable for some people. You might try SNAPTYPE=0 to disable adaptive grid snap.

  • While setting SNAPMARKERSIZE=10 and SNAPMARKERCOLOR to a personal preference help a bit - the biggest improvement comes from a very unexpected source. Setting COORDS=0. That makes a huge difference.

    Somehow having active coordinate display makes the cursor jump to some specified precision (don't know what that is yet). In A-Cad, turning off coordinate display improves performance and prevents some screen corruption - but it made no difference in mouse movement. Here...it's like another level of grid.

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam