Drawing rotates while editing a 90° rotated text

Does anybody know if there there is a setting which prevents rotating of the whole drawing while I'm editing a 90°rotated single text?

Comments

  • Don't you agree that's a feature, which makes it easy to edit rotated texts? The drawing rotates back when you finish editing the text.

  • But if you do not like it: set the value of the MTEXTFIXED system variable = 0

  • Thanks a lot. That's what I need.

  • I liked that auto-rotate feature, and I miss it. I turned off MtextFixed because I don't like the auto-zoom part.

  • @Anthony Apostolaros said:
    I liked that auto-rotate feature, and I miss it. I turned off MtextFixed because I don't like the auto-zoom part.

    After the edit session, it zooms back to the previous display. So no reason to switch it off for that.

  • @Louis Verdonck said:
    After the edit session, it zooms back to the previous display. So no reason to switch it off for that.

    I turned it off because of what happens with large mtexts. I use a lot of those. When I click on one to edit it, I'm already in the right location for editing. I had to go there to find the paragraph that needs to be edited. But auto-zoom moves me out to where I can't read it. So I have to zoom back in again to make the edit.

    That's not a big problem, but it becomes a nuisance when I'm editing a sheet full of columns of large mtexts. And auto-zoom doesn't do anything I want except for auto-rotation. But I rarely use rotated texts. So instead I just hit F7 (which rotates the selection set 90° and keeps it selected) as many times as needed, then do the editing, then use F7 again.

  • It is important that the variable exists and that everyone can use it by his own assessment. (next mission: fighting for SNAPGRIDLEGACY).

  • Thanks for pipointing what's been annoying me - I zoom to see the bit of Mtext I want to edit, double-click to open editor, it shoots off sideways and I have to pan and zoom to get it back to visibility. MTEXTFIXED stops all that - great!

    MTEXTFIXED, in Settings, 2 is "rotate and zoom". 0 and 1 are same - "do nothing". Wondering if 1 is supposed to be "rotate about cursor but don't zoom" but it got lost somehow. That wd be the setting I'd choose.

    What's this about F7? For me it does nothing but opening grid.

  • Good to know.
    AlthoughI did not work much with Text so far.

    But

    I zoom to see the bit of Mtext I want to edit, double-click to open editor, it shoots off sideways and I have to pan and zoom to get it back to visibility.

    is similar to my problems with UnDo including View Changes.
    Unfortunately there is no similar Setting for it in Bricscad

  • Anthony Apostolaros
    edited January 20

    @Tom Foster said:
    What's this about F7? For me it does nothing but opening grid.

    Tom, I have my F7 key set to issue the attached custom command. I do that with Macro Express, but I believe it can be done in the Keyboard tab of Bricscad's Customize window.

    The last line of code keeps the selection set selected so you can keep pressing the F7 key and make it spin around.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!