MLeaders - Ortho


Maybe somebody can help.

-When doing a new MLeader note on a drawing, after the 1st point and going for the 2nd 'landing' point, the tool will not obey the ORTHO key (F8) restrictions. It remains loose and thereby an additional step is needed to "line things up" properly afterwards.

-Is there a setting for this? or is this just the behavior in BricsCad?
(In autocad, the mleaders will go fully horizontal or vertical when the (ORTHO/F8) is engaged, which helps a lot during production.

Any help is appreciated.

Thanks in advance.


Best Answers

  • Michael Mayer
    Accepted Answer

    Yes, it is often misleading.
    When I get such messages, I usually open the Sub Forum in a new Browser Window
    and most often I see that the Post is already there. Seems like just the original
    Browser Window where the post was written, somehow lost connection to
    Forum Server. Or something like this.

    You can "Flag" your own Post, so a Moderator gets informed and maybe deletes it for you.

    Back to Topic, I also a friend of right angles ....
    so I think it is worth to file a Bug or Feature Request.

  • Roy Klein Gebbinck
    Accepted Answer

    Try switching on Polar tracking.


  • So sorry for posting multiple times, it was giving me an error and to try again in a few minutes. So I did. Also, I can't figure how to remove a post.

  • Anthony Apostolaros
    edited March 2021

    I don't use Mleader, so I don't know how it's supposed to work, and I couldn't figure it out when I tried just now. But if you don't like the way it works you can use Lisp to make a custom version of it that works the way you want. I made a custom version of the original Leader command that draws a 2-segment leader starting at the text. It draws the first segment with Ortho on, then the second segment with Ortho off, ending in the arrowhead. Then Ortho is restored to whatever it was before using the command.

  • I know it's been a while, but using Polar instead seems to work as desired. Thanks!

  • Try the setting maximum leader points set to 2.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!