Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Improving point cloud displays

edited September 13 in Point Clouds

I'm trying to improve how a point cloud appears in BricsCAD. Thus far, I can't get the same resolution / results that I can in AutoCAD. I've played with the various settings, and also increased the point max variable with no improved results. It seems that the implementation in Brics is more geared to showing things like walls and solid surfaces rather than objects such as pipe and thinner handrails. Or am I missing something? The current form is not workable for me, and BricsCAD is also a lot less responsive than AutoCAD when it comes to orbiting and zooming. The pointcloud shown in the screen shots is a 1.3GB RCS file, but I'm not above using another format if it works better. I've had similar issues with smaller RCS files. Screen shots attached from BrisCAD 21 and Acad 19.

Acad Point Cloud.jpg
1086 x 1225 - 467K
Brics Point Cloud.jpg
1109 x 1205 - 344K
Acad Zoom Point Cloud.jpg
1420 x 1246 - 1004K
Brics Zoom Point Cloud.jpg
1238 x 1180 - 661K

Comments

  • Hmmh,
    I am not experienced with point clouds.

    But in latest Bricscad Releases, beside just scaling point sizes,
    there was a Point Cloud auto setting, that scaled point sizes
    according to point density for less covered areas.
    Which made the scene much more legible than what I have seen
    anywhere else ...

    Maybe that is more applicable to mostly flat surfaced only geometry (?)

  • Is the setting POINTCLOUDADAPTIVEDISPLAY enabled? (That is the setting Michael refers to I suppose.)

    You may also want to try the V22 beta - if you are interested, please enter a support request and ask for beta access.

  • Hi Vince,

    Just by looking at the screenshots I can tell you that this is NOT how pointclouds are supposed to be displayed in BricsCAD. There are a couple of settings related to display that might help you here:

    POINTCLOUDPOINTMAX - this setting adjusts the maximum number of points displayed at each moment. If you set this too low, the pointcloud will have a low resolution, and too high might make things slower depending on your system. A number around 4 million would work well.

    POINTCLOUDADAPTIVEDISPLAY - turning on this options would automatically increase the size of points in low density regions to give a more natural look. You might want to try both states of this option to see which works better for your case.

    POINTCLOUDPOINTSIZE to decrease and increase point sizes.

    Another thing that might have caused the problem here is the import unit which is prompted the first time that you attach/process a pointcloud in BricsCAD.

    "Give unit for point coordinates. [Inches/Feet/Miles/miLlimeters/Centimeters/mEters/Kilometers/micrOinches/milS/Yards/Angstroms/Nanometers/micRons] :"

    For RCS files, the import unit should be set as METERS (this is automatically set in the latest versions).
    If you've chosen another unit, please delete the pointcloud from cache (POINTCLOUDDELETEITEM) and re-import it with the correct units.

    If none of these work, I would suggest to create a support request so we can specifically check the pointcloud you're working with.

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam