VIEWPORT ALIGNMENT

Why do my viewports in paper space not stay in alignment with the base view? Is there a setting to correct this?

Answers

  • You could try different settings of AUTOVPFITTING and VPROTATEASSOC as well as the ANCHOR Option of the VIEWEDIT command, but I bet it won't solve your problem: If the bounding box of the displayed geometry changes (e.g. because you changed visibility of a layer), the view content will be re-positioned. This behavior certainly looks erratic to me, but maybe it is just a faithful re-implementation of AutoCAD oddities...

  • Knut, Hohenberg, when you create views in AutoCAD using the Viewbase command the projected views stay aligned with the base view, unless you turn off fixed justification in the projected view's properties. I have not been able to find that setting in BricsCAD. I'll look into the settings you suggested and update.

  • From what I can see, the Viewbase and associated viewports (projected, section, detail) in BricsCAD are more like standard viewports in AutoCAD. When you insert them into your layout the associated views, other than detail views, are aligned with the base view, but you can move them independently.

    I need the associated viewports' alignment to be locked to the base view. Does anyone know if this is possible through settings, or has anyone heard of a lisp routine or macro that will accomplish this?

  • the only thing that works to some extent is to anchor the drawingview viewports and not manually move them. Upon scale change they still align but may start to overlap and then you would need to manually move some of the projected views. Other than that they are not connected.

    I did submit a request for an option to anchor drawingview viewports by default to avoid some issues with those views moving around, but still have to go through the settings if this has been implemented.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!