macOS Ventura vs V22

As every year,
next macOS Ventura Public Beta will arrive in July.

So, does V22 still run on Ventura in the Developer Beta?


  • I am on macOS 13 Ventura Public Beta now.
    So far it seems like Bricscad V22 will still work ....
  • Thanks for being willing to try Ventura. I assume you are on the current version of V22 - BricsCAD-V22.2.05-1-en_US as well.
    Is the User Interface (like the Command line panel and toolbars) still not loading reliably? Not that it is difficult to get it back if it fails to load.
    For the record I am still on Big Sur on my Intel Mac and Monterey on the M1 MBA and both have the same problem.
  • Michael Mayer
    edited July 2022
    > Is the User Interface (like the Command line panel and toolbars) still not loading reliably?

    As expected - no.

    Each time I open Bricscad it looks a bit different.
    Right Dock Palettes Tabs mixed up again or some Bricscad Palettes deactivated again or
    Command line minimized again or Ribbon deactivated or likely everything at a time.

    I have never seen the Bricscad GUI on Mac working as expected since I started with Bricscad.
    I assume this is a Bricscad problem, not a macOS problem.
    It is likely that the GUI system will not repair itself just by any new macOS versions.

    When I open Customize UI and click OK without having done any changes, I usually lose
    my Left Dock with the Structure Panel.
    When I try to deactivate those Palettes and reactivate again to bring them back, I see
    that I can't even deactivate them from Menu entries.

    I think we should even feel lucky that there is a Bricscad Mac version at all.
    I would not bet that Mac Support will even continue with V23 or later.
    We'll see ....
  • Yes, I agree. Bricscad on my M1 Mac is not a reliable experience but for that matter neither is ARES Commander. The only reliable CAD applications are the likes of TurboCAD or even Q-Cad. AutoCAD of course but that comes at a very high price. I have perpetual licenses for both ARES and BricsCAD but have decided they can only reliably operate in a Windows environment. I only have TurboCAD V12 on my Macs.
  • I think Bricscad on Mac is pretty stable meanwhile.
    I could work on Mac. Even on my M1.

    If I had a crash and filed a SR, it was usually fixed with the next update.
    Beside, for me, missing important features (like Datasmith export),
    it is just that these UI issues got never under control or fixed,
    since years.
    And this is for me what makes the Windows Version feel like a completely
    different experience.

    Annoying and pity but not 100% a deal breaker.

  • True Michael, usually though if I try to open a drawing by let's say clicking on the drawing it will cause the app to crash. Now, if I open the drawing by going to Bricscad and open it from the menu bar, no problems. Not a very complete experience.
  • Michael Mayer
    edited July 2022
    Yes, same here but not in all cases.
    AFAIK it is ok to double click on a file in Finder or Desktop - as long
    as Bricscad is already open (with an empty file ?).

    Same when you open a Bricscad/Version Screen/Welcome Screen/ ....
    and click on a file or for new file - before Activity Manager CPU usage
    settled down - Bricscad will crash .....

    As pity as it is - I am already used to it.
    So I open BC, go through all welcome screens - and wait ...
    (Sometimes I even watch the Activity Monitor Dock Symbol - until
    cooled down) before I open any File.

    Not satisfying but crash preventing ....
  • Just Installed V22-2-05-1 on my new M1 Max MBP with 32 core GPU and 64 GB Ram. Runs my 5 k screen at 5120x2880 at 100 hz. Very impressive.
    As it is a new install I had to set BricsCAD up with toolbars and found the Panel would not dock on the right and also could not get the Command Line panel below the Properties panels.
    Have it working correctly on my M1 MBA but then I did update it from V22-2-03-1
    Have raised a support request.
  • Managed to sort the Properties / Command line panel out myself - with a hint from my CAD supplier. Seems to be stable now although the Command line panel does not always load. Easily brought back with a right click in the panel area and checking a box.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Click one of the buttons on the top bar to get involved!