Has anyone been successful making a change to the XDWGFADECTL variable, and the display actually changing? I don't see any difference. 0 is supposed to turn off the fading, but it's not working on my Mac.


  • On Windows, I have to regen after changing the setting. The display changes after the regen.
  • Thanks. It doesn't appear to work the same way on macOS. I tried both REGEN and REGENALL—no difference.
  • OK, this one's on me...

    I think I figured it out. In addition to XDWGFADECTL the system variable LAYLOCKFADECTL was also coming into play. I typically reference XREFs on G-XREF layer, then lock the G-XREF layer to prevent it getting in the way of the current discipline or projection I'm working on.

    While XDWGFADECTL was set to 0, LAYLOCKFADECTL was set to 50. Setting it to 0 and then running a REGEN command brought it back to it's full vibrancy.

    I hope this helps someone else who runs into this issue.

    Also, I really wish BricsCAD would just include the REGEN function at the end of the *FADECTL commands. I don't see any reason to have to run two commands to accomplish one action.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Click one of the buttons on the top bar to get involved!