New Cursor features on Mac ? not for me

I found some entries in Release Notes that made me hope
that I could finally get a Full Size Crosshair Cursor on Mac :

CROSSHAIRDRAWMODE

The default value of the CROSSHAIRDRAWMODE variable was set to 3, meaning that BricsCAD should use a rendered cursor both in 2D and 3D visual styles. This fixes several problems reproducible with the previous default value.
CURSOR

The cursor no longer hides in Model Space when a PDF is attached.
SR116492
CURSORSIZE

The size of the cursor can be set to a value greater than 10 with CROSSHAIRDRAWMODE setting changing to 3 (rendered cursor) for V24.
SR63364
SR63585
SR64333
SR65680
SR65810
SR66038
SR66641
SR67081
SR67406
SR70212
SR71161
SR73111
SR73832
SR74033
SR77437
SR77788
SR78598
SR78712
SR80654
SR80731
SR81096
SR82648
SR118040
SR121953
SR123010
SR123035
SR125453
SR130693
SR144746
SR145887
SR146083
SR150034
SR151461
SR160645


But I still do not get it working.
Setting cursor size (%) to more than 10 leads to - no Cursor at all for me.

Same if I activate 2D/3D Cursor graphic settings to the default of "OpenGL"
again no Cursor at all for me.

Comments

  • Hello,
    The issue is solved in the latest version of BricsCAD (24.1.07). The default value of CROSSHAIRDRAWMODE is 3 and CURSORSIZE should work accordingly. Besides, go to Settings > 2D Graphic system device > OpenGL.
  • Thanks Patricia,
    I think it answered the question.

    As I played with those Settings already before when testing,
    when starting latest Bricscad V24, CROSSHAIRDRAWMODE was not 3 (But both 2D and 3D off)
    and cursor size 8.

    So I set cursor size to 100 - still no cursor at all.
    Thenset drawmode to 3 - still nothing.
    So I went to a 2D top view - still nothing.

    So I thought it may only work in 2D and switched view mode from BIM to 2D wireframe
    and - tada - I have seen the first full screen cursor on Mac after a decade.

    I switched back to BIM view Mode and it is still there.
    Switched to an isometric view, still full cursor.
    Closed and reopened the file, still full cursor.

    So maybe switching to 2D wireframe were just needed to recativate the viewport and GPU
    and a restart would have done the same.

    So until I come back missing full screen cursor again,
    I think it works now.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. Click one of the buttons on the top bar to get involved!