BOM Grouping Issues


I am using the BOM to get takeoff quantities from BIM profiles. In the one drawing I have the BOM that lists all the parts, but the BOM is not grouping the items together. See below.

I then save the BOM as a template, create a new drawing, copy the parts to the new drawing and create a new BOM using the template from the previous drawing. The parts then correctly group as intended, see below.

All the BOM settings are the same, but the output is not the same, so not sure what is preventing the first BOM from grouping the items together. See attached files.

Any help on this would be appreciated.


  • Further to this, is there a way to extract the bend angle for a flow fitting shown in the properties panel? The properties panel would show either 45 or 90 deg bend angle, which is greyed out, but the bend angle in the BOM shows a different value. See snipping below.

  • Hello.

    I checked both drawings and there are a few differences between them.

    The NotWorking drawing seems to be part of a BIM project.
    There is a missing project database file, located in Z:...

    Because of this, I couldn't perform a thorough test.
    There were some missing properties, like profiles and compositions - there were probaly stored in the missing database.
    The missing properties (profile) prevented the grouping to happen.

    There was also a filter applied to the BOM in NotWorking, no filter in the Working drawing.
    The filter rendered the BOM empty, there was no record to match the filter.
    The Working file also had the filter, but the required properties (Ulmo) were defined here.

    I removed the filter - with this the BOM was correctly populated.

    Finally, I removed the column with missing properties.
    I didn't check every setting for every column.
    I deleted all columns and added them again, less the profile column.
    With this, the grouping worked fine.

    Regarding the bend angle, the issue seems to be related to how the column is formatted by default.
    The default format does not look good.

    A quick solution is to format the column as decimal.
    Then, it will display the expected value, 90 in this case.
    The angle is taken from the model and added to the properties when the entity is calssified as Flow Fitting.

    Another solution could be to define a custom property and assign a value there.

  • Great thanks for the helpful feedback, I will look into your suggestions.