Persistant Ribbon in custom workspace

Hello,

I'm a familiar user of Bricscad V16 to V21 on both mac (intel core) and Windows and I'm currently trying V24 (V24.2.0.8) on a new mac mini M2 Pro.

I've a strange issue with the interface (still problematic on Mac in my experience) : for personnal reasonss I like to use only a few toolbars and not the Ribbon. So the first thing I did was to create my own Workspace with the choosen toolbars and with ribbon closed. It works in the frist drawing I had opened, but when I open 2 or more drawings, the ribbon come back every time I switch from one drawing to another.

After RIBBONCLOSE it dissapear, but then when I move to another drawing it come back everytime.

I looked to the customization parameters and I can "empty" the ribbon inside my own Workspace, but I can't remove the main RIBBON category.

After a quick look around on the forum I can't find another similar issue : is someone experiencing the same trubble ? May it be linked to the version or to the fact that I'm currently working with the TRIAL version ? I wished to test it before purchasing the new licence, as I must decide if I dedicate this computer to CAD or not.

Thanks !

Comments

  • I also prefer to use only toolbars (really dislike the ribbon) and have a selected set for each workspace (2D or 3D or Modelling etc) as that way I am most productive and have the same problem.

    It is still present on V24.2.06 on my M1 Max MBP. Has persisted for the entire time of running V24. For a while I even went back to V23 as it was so irritating. If you have a V24 license you can still run V23 at the same time.

    The easy way to get rid of the Ribbon is to right click on the side of the drawing area, or in the ribbon itself, move your mouse to the "Panels" area and uncheck the Ribbon panel.

    Unfortunately the Ribbon reappears every time you open an existing or new drawing or go move to an already open drawing.

    Will raise another service request on the issue.

  • I should add that I have gone to the Workspaces toolbar/Customise and in the 2D Drafting - Toolbars (custom) workspace have tried to delete the Ribbon. I could not do so, so deleted all to ribbon sub panelsand unchecked the Ribbon Panel.

    Possible reason this did not work is that there is no sign of the custom 2D Drafting - Toolbars option although when I open BricsCAD up I always select the 2D Drafting - Toolbars option and my custom toolbars are all there.

    Have raised a Service Request.