Speed up BricsCAD when doing BIM?

When working in BIM, drawing electrical or piping, almost every task is extremly sluggish.

Rotate the view a little bit - Long pause

Add a component from the library - Long pause before I can position it

Adjust a section plane - Long pause

Everything I do is slow and sluggish.

The building is I`m working on at the moment is a 2 story small building.

It also crashes frequently and I`ve only just started putting in the blocks.

The Windows task-manager doesnt show any sign of high use of neither CPU, GPU or RAM, so I dont really know what the bottleneck is.

The computer is a MSI P65 "Gaming laptop", Windows 10, Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz, 32GB RAM, NVidia GTX 1660 Ti.

Got any tips on how to speed things up?


  • You can check all of Windows Energy saving settings,

    check the Nvidia Settings and assign Bricscad manually to use full GPU power.

    Maybe currently Windows will assign only the week onboard graphic on the CPU

    to Bricscad.

    AFAIK by default Windows defaults everything to energy saving, even on desktops.

    I had all my CAD and 3D apps manually assigned in Nvidia Settings and changed

    most Windows energy settings selectively to full power.

    Also I always had AMD Ryzen CPUs, which didn't have onboard graphics that could be

    accidentally used.

    Even on a (mobile) Mac you should deactivate such energy saving features for

    demanding CAD or 3D Apps.

  • I have an i9-13900K with a 4090 OC and I get the same issue with lag,. I have set nividia control panel to force use 3D, unless there are specific settings that Bricscad would benefit from I think it's more related to the CPU unless you are rendering textures and light sources. I'm still looking for more information about this topic.

  • i9-13900K with a 4090 OC,

    That’s a beast, have you played with MTFLAGS in settings?