Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Invisible selected objet

In any version from the firsts beta release I have  found a problems with the selection of the object(line, poly-line, text, bloc...).

My system is:

Dell Inspiron 9400 with ATI X1400 and Ubuntu 10.04 OS.

Every time I select a object it become of the same color of the backgorund(any color) an so invisible.

Loock the pictures below to better understand what i mean:


http://img176.imageshack.us/img176/2268/83479140.png
http://img85.imageshack.us/img85/7105/85401710.png
http://img545.imageshack.us/img545/4269/19273097.png
http://img337.imageshack.us/img337/2816/40052750.png
http://img295.imageshack.us/img295/3281/50767905.png

What have I to do to solve it?

Thanks

Stefano

Comments

  • Stefano,

     

    I've the same "problem" on mine desktop with a ATi X600 graphic card.

    I've tested with various distro's, same porblem.

    I think the problem lies with the X-org radeon-driver.

    When I change the graphic card with a nVidia card, no problem (X-org nv-driver and the proprietary nVidia-driver).

    I also have two older DeLL laptop's (CPx & C610) also with a ATi graphic card. These have not that problem.

     

    I reported this bug to BricsCAD4Linux......

     

    Maurizio

     


     

  • Do not any work-around exist to fix it?

    Stefano

  • Stefano,

     

    I fixed on mine destop with disabling DRI in the /etc/X11/xorg.conf file.

    Tested on the same PC Mandriva 2010.0, Fedora 13 and Ubuntu 9.10 all 32bits.

    Fedora and Ubuntu don't have a /etc/X11/xorg.conf file anymore.

    Create the file and put those three lines in it:

     

    Section "Module"
        Disable "dri" # direct rendering
    EndSection

     

     

    Restart the X-server...

     

     

    Ciao

    Maurizio

     

  • I tried the "disable DRI" trick, but this caused my Ubuntu to not start X at all.

    I had to boot with a live CD to remove the xorg.conf.

    Perhaps it makes a difference if you're using 9.10 and 10.10 (I used 10.10).

    Greetings,

    Peter

     

  • Peter,


    Indeed, with Ubuntu 10.10 it won't work. Maybe a bug in 10.10.

    Even with a full (re)generated xorg.conf file, and disabling DRI and DRI2: -> http://ubuntulinux.co.in/blog/ubuntu/ubuntu-9-10/xorg-conf-file-create-on-ubuntu-9-10/

    I can't find anything in the log-file that can help me.

    Ubuntu 10.10 wil start and than leave black screen (my screen go in sleep-mode)

    Only with the key combination <Ctrl>+<Alt>+<F1> and than <Alt>+<F7>, I have my login-screen vissible....

     

    Maurizio

  • Peter,

     

    This seem to work with me and Ubuntu 10.10; Maverick Meerkat!

    In the section 'Monitor' add  Option "IgnoreEDID" "True"

    My full xorg.conf file: http://users.telenet.be/x86_64/Scripts/xorg.conf

     

    Maurizio

     

  • Maurizio,

    Thanks, I'll try again.

    Peter

     

  • Maurizio,

    I have tray your configurations, It works bu all became very slow...

    Is the same for you?

    Setefano

  • Stefano,

     

    It's logic, you have disable DRI.

    You can't play Tux-Racer decent etc etc.

    Untill Bricscad haven't slove this issue. It's the one of the other.

    Maybe with the next ati-driver:

    http://www.phoronix.com/scan.php?page=article&item=mesa_r300g_oct10&num=1

    http://www.phoronix.com/scan.php?page=news_item&px=ODYzNQ

     

    Maurizio

     

  • hi, i'm new in bricsad...i have the same problem with selections. I use a notebook acer aspire 1690 with an ati mobility radeon x700. I would like to install bricscad on another pc with ati radeon hd 4850. Someone know if it works correctly? Thanks!

  • Sebastiano,

    To be honest.... I don't have a ATi-card that is supported by the proprietary fglrx-driver.

    I think it would not be a problem with the fglrx-driver.

     

    Maurizio

     

  • I used fglrx drivers in a previous ubuntu installation (my radeon x700 is supported), but i had various problems and the system was too slow, so it's one of reasons i decided to use opensuse, because here the opengl works, but i have problems with some applications. Now i'll try to install fglrx in opensuse. I also tried to disable dri as you said, creating a new xorg.conf, but my X didn't start, so i deleted it again!

  • Sebastiano

    I use ATI proprietary drivers on my Fedora with ATI Radeon HD 4350 and works properly. Nvidia is definitely better, but ATI definitely usable.

  • Also have same problem on my ATI graphics Xpress 1100(already many times posting in this forum)

     

    > glxinfo | grep render

    direct rendering: Yes

    OpenGL renderer string: Mesa DRI R300 (RS400 5A62) 20090101 x86/MMX/SSE2 NO-TCL DRI2

    [image]
    try to use work around
    [/image]
     Option "IgnoreEDID" "True"
    does not help, I will try to disable dri, but have a bit confusion with this workaround
     have no problem with inkscape, scribus, dia, ooo, qcad, AC and other software.
     I am stil thinking it is bricscad related problem...

     

  • does not find any module section to disable dri and dri2

    user@host:~> ls /etc/X11/xorg.conf.d|grep odule

    user@host:~>

  • I used DRIconf 0.9.1 (via synaptic). It's a graphical interface and you're able to select different dri related options. It's just a workaround but you can change the "dri-options on the fly", so you can use google-earth and(!) bricscad. I don't know if it is only ati-related, my graphic is an meanwhile legacy-card ati-X1250, which worked under hardy (fglrx) but is not supported/developed by amd/ati anymore (according to my google-research). On DRIconf i changed  "the low-impact fallback" and the "disable GL_EXT_stencil_two_side" option from yes2no (and revers). 

  • Andrey,

    From Ubuntu 9.10 is that xorg.conf is missing. The reason for this is that the configuration to be done on user level. The file xorg.conf will be in use only if it exists.

    You have to generated one and edit this file manually. Or use DRIConf as Oliver described (Thanks).

     

    Maybe with Ubuntu 11.04 and the 'new' AMD's R300 Gallium3D driver.

     

    Maurizio

     

  • I had the same issue in Ubuntu Maverick with an old ATI card. But I found a way to fix it:

    In BricsCAD go to 'Settings/Program options/Display/GL selection highlight style'

    and select "Use a thickened line for highlight" instead of the default "Use line stipple for highlight". That's all.

    I'm using fglrx. It seems the problem is the way the driver handles those stipple lines.

    .................

    By the way, I also had problems with the selection area efect and selection preview higlight. You can just turn them off in 'Settings/Program options/Selection/Selection area and selection preview.

  • @Maurizio Dal Magro

    http://help.lockergnome.com/linux/gentoo-user-change-X11-xorg-conf--ftopict513214.html

    In the future Xorg will move to a slightly different setup with files 

    under /etc/X11/xorg.conf.d/ instead of just one file but I think that's 

    for xorg-server-1.8... (or even later). And HAL is replaced by libudev 

    (yay!).

    xorg.conf is old way, but I know it working when exists, in previous post I mean what file should correspond with module section.

    DRIConf looks like debian/ubuntu specific tool, opensuse use sax2 till 11.1

    AMD's R300 Gallium3D driver.

    good idea I  will looking for that.

    @Jose Luis Esteban Ruiz

    thank you  that really helps :)

    Still think that bricsys should fix this bug... but at least that workable on my video. I have plan to buy new laptop with ati graphics (I have intel on desktop, does not like) for now my chois is amd

  • I updated X11 and mesa from  OBS: X11:/XOrg/openSUSE_11.3/ repository, and I found a performance increase approximately by 50 percent with new gallium driver r300

    > glxinfo|grep OpenGL

    OpenGL vendor string: X.Org R300 Project

    OpenGL renderer string: Gallium 0.4 on RC410

    OpenGL version string: 2.1 Mesa 7.9

    OpenGL extensions:

    also I roll back  to default settings in Settings/Program options/Display/GL selection highlight style and have visible selected objects!!!
    thank you all, this problem is completely fixed for me
    have fun!
    Look like I finally I need to buy bricscad... :)
This discussion has been closed.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam