Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Bricscad v16 random crashes

Hello, i'm new to Linux and don't know it well, i downloaded and activated my student license for Bricscad and it crash continuously, dunno if i did something wrong or it missing some kind of library or package, i know its not the right distro to work with(i have Kali Linux), soon i will replace it with openSUSU or Ubuntu.
Some infos about my specs:
Video card: Intel HD 4000
CPU: i5-3340M
Kernel Version: 4.3.0-kali1-amd64
Crashes that i get today
 [code]User@kali:~$ cd /opt/bricsys/bricscad/v15
User@kali:/opt/bricsys/bricscad/v15$ ./

(bricscad:2111): Gdk-CRITICAL **: IA__gdk_cairo_create: assertion 'GDK_IS_DRAWABLE (drawable)' failed
Segmentation fault
User@kali:/opt/bricsys/bricscad/v15$ ./

(bricscad:2149): Gdk-CRITICAL **: IA__gdk_cairo_create: assertion 'GDK_IS_DRAWABLE (drawable)' failed
Segmentation fault

Crashes that i get on first run
[code]User@kali:~$ cd /opt/bricsys/bricscad/v15
User@kali:/opt/bricsys/bricscad/v15$ ./
[2353:2384:0412/] handshake failed; returned -1, SSL error code 1, net_error -101
Segmentation fault
User@kali:/opt/bricsys/bricscad/v15$ ./
User@kali:/opt/bricsys/bricscad/v15$ ./

(bricscad:2673): Gdk-CRITICAL **: IA__gdk_cairo_create: assertion 'GDK_IS_DRAWABLE (drawable)' failed
Segmentation fault
User@kali:/opt/bricsys/bricscad/v15$ [WARNING:flash/platform/pepper/pep_module.cpp(63)] SANDBOXED
Vector smash protection is enabled.
[WARNING:flash/platform/pepper/pep_module.cpp(63)] SANDBOXED
Vector smash protection is enabled.[/code]


  • My Bricscad version is not V15 but V16 (BricsCAD-V16.1.09-1-en_US-amd64)
    Is there any method to modify the topic ? Because i don't see any buttons there or on my profile :/
  • Hello Cristan,

    I have no experience with Kali Linux.  But being debian-derived there should be a a good chance to run BricsCAD decently.

    I cannot tell for sure but I would guess it is your graphics card.
    Unfortunately hardware acceleration is not well supported on an INTEL card.
    There is a chance it helps to install the most recent proprietary driver.

    I quote from our knowledge base article What are the BricsCAD minimum system/hardware requirements? :

    "3D graphics hardware acceleration in RedSDK on Linux is NOT supported on:
        INTEL cards. As opposed to ATI and NVIDIA, 3D hardware acceleration in linux drivers for INTEL cards is relatively new. So far we do not yet officially support 3D hardware acceleration on INTEL cards, although we are working on it."

    You could try switching to a visual style that does not use 3D rendering.
    Inside BricsCAD, in the properties bar at the right, you can find "visual style".  If you can pick 2dWireframe or Wireframe, then no 3D rendering with hardware acceleration will be used.  For many workflows 3D graphics acceleration is not needed for practical work.

    Another complication could be your window manager.  For instance, the standard window manager in Ubuntu uses hardware acceleration, which could disturb other programs that want to use it.  In Ubuntu one could try to use a "Gnome Flashback (Metacity)" session.  I do not know what options Kali has.

    For further support, please enter a support request, and attach a backtrace (see our knowledge base article How to create useful backtrace on Linux ).
    We will not be able to reproduce on Kali (there are simply too many distributions to make this viable) but a backtrace could give us a useful clue.

This discussion has been closed.
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam