Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Issues with Ubuntu Bionic / Puppet 5.4.0

We have upgraded to Ubuntu 18.04 which has Puppet 5.4 in their repositories.
When trying to install BricsCAD (either v17 or v18) it wants to remove Puppet (which uses libcurl4 in its dependecies) from the system, which is clearly not what I want.
Can I modify the package and set the dependency to libcurl4 ? If that is no big deal, I'll do that, otherwise: Is there any workaround ?

apt-get install bricscadv18
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 bricscadv18 : Hängt ab von: libcurl3 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
apt-get install libcurl3
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  hiera libboost-log1.65.1 libleatherman-data libyaml-cpp0.5v5 ruby-augeas ruby-deep-merge ruby-json
  ruby-selinux ruby-shadow
Verwenden Sie »apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  facter libcpp-hocon0.1.6 libcurl4 libfacter3.10.0 libleatherman1.4.0 puppet
Die folgenden NEUEN Pakete werden installiert:
  libcurl3
0 aktualisiert, 1 neu installiert, 6 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 0 B von 214 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 12.7 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] n

Comments

  • I can't remember having had that message.
    I tried Kubuntu 18.04

    What I notice is that the File > Open Dialog disappears or
    moves behind the App Window and isn't reachable.
    (You have to make App Window smaller to not occlude
    the Dialog)

  • Can I modify the package and set the dependency to libcurl4 ?

    Yes you can.

    Our rpm installer already depends on libcurl4.
    For some reason Ubuntu (as well as other Debian-like distro's I guess) stayed on version 3 a lot longer.
    As far as I know there are no drawbacks to using libcurl4 instead of libcurl3.
    We intend to update our deb installer in a next version and update the dependency from libcurl3 to libcurl4.

  • Yes you can.

    I just edited the control file in the deb file of BricsCAD 17 following the instructions on https://unix.stackexchange.com/questions/138188/easily-unpack-deb-edit-postinst-and-repack-deb and now it works flawlessly under Ubuntu 18.04.

  • An instruction in german language to install BricsCAD in Ubuntu Linux 18.04 can be found here: https://bauforum.wirklichewelt.de/index.php?mode=entry&id=11633

  • @Tijs Vermeulen said:
    Yes you can.

    Hi Tijs, thanks for the info, works perfectly, thanks !

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam