sweep issues

Hi, help needed.

I'm still new so sometimes I do things that don't work. So I created this surface/object??? I'm trying to sweep it on a rectangle. Sometimes it works other times it doesn't. It does but the wrong way. So I'm creating a window frame (ornate frame). When I go to sweep, either it does it like perpendicular even if I click "no" or in the inside of my path instead of the outside.

I've attached the shape and path and then the final design. You'll the the ornate piece is on the inside instead of the outside and the lower curve is on the outside instead of inside. It reversed it.

Help please? I've tried different options ie outside polygon, outside window, alignment, etc...


  • weird, I just did a rectangle with a polyline and it worked??? why didn't it work with the rectangle?

  • Roy Klein Gebbinck
    edited May 2019

    A rectangle is just a polyline, there is no rectangle object in BricsCAD.

    The _Sweep command is a bit tricky.
    I always create my profile entity in the XY plane of the WCS (use the _Ucs command to change the coordinate system) so that I know the direction of the normal of the entity. The normal is the direction in which the profile will move along the path and with this approach it matches the Z axis. And the X axis indicates how the profile will be rotated (default rotation in the direction of the 2nd derivative? or the centroid? of the path).
    The profile is swept from the start of the path to the end. So the direction of the path is also important. You can use the _PEdit command to reverse a polyline.

    In the image the direction of the path (the rectangular polyline) is CCW. Apart from specifying the base point (BL corner of the profile) the default _Sweep options were used. For clarity the resulting solid was moved.

    It may be useful to change the DELOBJ setting.

  • @Roy Klein Gebbinck thank you so much. That's super helpful. I appreciate the exemple. Thanks. I'll try that on my next one. I'm building a library of Windows, frames and doors etc...
  • Agreed that sweeps are tricky biz, especially when working with a closed polyline. If a profile doesn't "behave" the way you'd like it to, a simple trick is to rotate it in 90 degree increments around it's base point until it sweeps to your desired result. Another issue with sweep can occur when a closed profile won't generate a solid thus the frustrating command line message "0 entities were swept successfully" . I find this can occur when my object is a closed spline. The solution in this case is to generate a region which will indeed yield a solid sweep.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!