Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Setting default version

V21 is not set as the default for opening files by double click. Double click in explorer opens .dwg files in V20. I tried resetting the default version for opening DWG in Windows Settings but the setting does not update. In the registry Bricscad.load.dwg points to CLSID {B7779432-1590-4823-9D12-76C167549CEE}, which is for V20.

I recall in the past having to play with various settings to get the newest version of Bricscad to active, but this is the first time I haven't been able to adjust settings to make the latest version the current version.

Any suggestions on how to fix this?

Comments

  • AFAIK it made V21 as the default App for DWG in Windows for me.
    I would need to check that.
    In macOS we have so far only the Beta Version for V21, so I am happy
    that it still defaults to V20.
    But to change it there, I could choose File Info, Open With, select App
    of choice, activate "for all file of this type and confirm with OK.

    I am pretty sure similar was possible in Windows from Explorer when
    changing default App for DWG from say Microstation to Vectorworks.

    Could be that it was in the same win7 dialog, a Tab "File Types" or such,
    like a Tab Visibility Settings for e.g. "hidden Files visibility" or show
    File endings and such things.

  • @Michael,

    Thanks for the suggestion. I tried exactly what you suggested before my first post. The current version did not update.

    Maybe best if I remove and re-install Bricscad V21. I try to not do that because my installation is highly customized and it takes a while to get everything reset, but it may be the only way.

  • edited December 2020

    @H Martin Shoemaker said:
    V21 is not set as the default for opening files by double click. Double click in explorer opens .dwg files in V20. I tried resetting the default version for opening DWG in Windows Settings but the setting does not update. In the registry Bricscad.load.dwg points to CLSID {B7779432-1590-4823-9D12-76C167549CEE}, which is for V20.

    I recall in the past having to play with various settings to get the newest version of Bricscad to active, but this is the first time I haven't been able to adjust settings to make the latest version the current version.

    Any suggestions on how to fix this?

    First of all, you should not have to do any of that.
    I have 20 & 21 on my laptop and there is no issue going back and forth.

    There are a few things I can think of off the top of my head.
    Could it be the license manager? Or is this a single standalone?
    I was wondering if it might be the target location in the desktop icon. Make sure it is pathed to V21 ("C:\Program Files\Bricsys\BricsCAD **V21 **en_US\bricscad.exe")
    How do you open dwg's? Whether it is BricsCAD or other CAD, best practice suggests opening CAD files from within the CAD software.
    Additionally, I think the two of you are on the right path, tracking it down.
    And if there is anything else that I can think of, I will send it along.
    -Craig

  • edited December 2020

    I opened Windows10,
    in Explorer I navigated to a DWG file,
    right click,"open with"
    Select other App,
    choose you App if not listed,
    activate "always use this App" checkbox,
    done.

    You can still open DWGs from Explorer, by "open with",
    with any registered App for DWG, when right click, Open With,
    and choosing your any other currently preferred App from the list.

  • You can use that, e.g. if you have Autocad and Bricscad installed,
    to switch between which App is default to open the File when
    you just double Click in Explorer.

    I use that quite often as I always have at least 2 redundant Apps
    for CAD or 3D, or even more.

  • edited December 2020

    Windows has a serious bug with "Select program to open ..." - it just verifies "name.exe", excluding the path to the executable ...
    so if you have V20 bricscad.exe assigned - and want to assign V21 bricscad.exe, in a different folder, then WIndows will detect "aaaah, 'bricscad.exe' already assigned, nothing to do" ...
    as long as "name.exe" is differently chosen in "Open with ...", as long Windows works properly - but not if "name.exe" is identical;
    those teenagers at Redmond obviously do not know that an executable has a path :smiley: since DOS times :smile: - correction : since all times (as stored on a persistent storage [megnetic tapes/disks/floppies etc)

    solution :
    regedit.exe, search all places of "bricscad.exe" ... at some point, you will find :
    "HKEY_CLASSES_ROOT\Applications\bricscad.exe\shell\open\command"
    and
    "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Applications\bricscad.exe\shell\open\command"

    there you can manually change which version to run.

    During startup, BricsCAD tries to automatically re-assign the ".dwg" to the actually running version (if .dwg was associated with BricsCAD), using the correct paths ... but this might fail if no admin access is available.

    many greetings !

  • "those teenagers at Redmond" Priceless!

    Thanks for all the replies. In the end I edited the registry to fix this. I found that I had to edit the "Bricscad.LOAD.xxx" entries in addition to the two that Torsten mentioned.

  • :smile:

    "those teenagers at Redmond" Priceless!"

    that is not only a joke !! It is confirmed by Microsoft : average age of developers at the Redmond Campus is : 23 (!!)
    those might be good programmers, no doubts (related to programming language), but software development is a little bit more, in fact ...
    and how many teenagers do you need in the team, if the team leader is 45 years (+/- 5) ? plain mathematics ...

    This also means, that majority of those developers have never studied at university - talented self-lerning youngsters, probably ... at least for a big part;
    and this missing understanding what "software" is (naturally, due to the age, missing experience) results in that style of MS software ...

    As I personally say : software is 90% thinking, and 10% keyboard :smile:
    have a great time to all ...

  • Thanks Torsten,

    I wasn't aware of that behavior in Windows.
    Maybe because I open Bricscad first before thinking about
    which file to open.

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam