ORTHO issue

With everything on the bottom shut off except ORTHO, how does one draw a horizontal line without the second point snapping to some object?

I need 3D entity snap on for the first point but want it off for the second to just use ORTHO to draw a temporary horizontal line.

Comments

  • F3 toggles esnap even during a command execution. Hold Shift to temporally use Ortho.

  • Thank you.

    I also found a work around. By hitting Enter before clicking on the second point, the line stays put and doesn't wander off to some snap point.

    Is this F3 and Shift key trick documented anywhere? I'm probably missing all sorts of tricks and short cuts.

  • Thank You

  • I'm still missing something.

    With everything shut off, I'm still getting an entity snap to happen.

    The attached image is an attempt to draw a line starting just to the top left of the sink bowl down. As soon as I click the start position, it immediately starts the line at the center of the work surface, not where I intended.

    How do I tell it to put the point where the cursor is?

  • @RoatanBill said:
    I'm still missing something.

    With everything shut off, I'm still getting an entity snap to happen.

    The attached image is an attempt to draw a line starting just to the top left of the sink bowl down. As soon as I click the start position, it immediately starts the line at the center of the work surface, not where I intended.

    How do I tell it to put the point where the cursor is?

    Looks like you've got the "zcenter" 3D entity snap active. (3D snaps show as blue symbols by default.) I've run into the same, and I think F3 toggles only 2D snaps (red symbols). So I have to also disable 3D snaps, manually, to avoid all entity snapping. Is there a setting to make F3 control all entity snaps (2D+3D)? Or another shortcut-key, or would we have to re-assign that?

  • ScottS: Thanks for the reply.

    In the image I posted, I have ESNAP turned off. I've turned off everything to try to figure out what does this. It does appear that it snapped to the center of the counter top, but with ESNAP off why would it do this?

    I copied the few objects involved from a large drawing to a new drawing and tried reproducing the effect but couldn't. ZCENTER on or off didn't matter with ESNAP on or off. Every line I drew went point to point as intended.

    So, I went back to the original drawing and copied the objects involved to a blank space and the problem reappears but slightly differently. This time on the start of line click it snaps to the center of the counter top. Before, I could start where ever I wanted but it would terminate at the center. With ZCENTER off, I can draw lines point to point as expected, but ESNAP is off the whole time.

    This is driving me nuts.

  • I don't know why. Maybe it was supposed to prioritize flexibility over usability?

    I am refreshing my memory about this. There are two separate settings: OSMODE controls 2D entity (or object) snaps, and 3DOSMODE controls 3D entity snaps.

    In addition to setting OSMODE=0 as you've already done by turning ESNAP off, try executing ZNONE command. That should set 3DOSMODE to zero, turning off all 3D snaps.

    I used to reassign my F9 key to "NONE" which is a command that sets OSNAP=0 if used alone, but can also be called transparently (without apostrophe), i.e., during another command, to temporarily disable object snaps on the next pick only. I stopped doing that in BricsCAD after having some other issues with re-assigned function keys, and F3 served most of my needs. But I think I may revisit NONE as it seems to turn off both 2D and 3D snaps.

  • I'm going to have to look up all those settings.

    This is getting confusinger and confusinger as Alice might say.

  • Now that's a perfect use for F4! Thank you, Louis. I'd gotten accustomed to not using F4 and missed that, or promptly forgotten it, in the release notes for v21.1.04.

  • I looked up OSMODE:
    OSMODE : Entity snap mode : Sets the entity snap modes and toggles entity snap on/off.

    Since this doesn't specify 2D or 3D, I assumed it meant both. I understand now it only refers to 2D. The ESNAP field in the status area has no effect on 3D entity snaps. It's a toggle for 2D entity snaps.

    I did some testing. Please let me know if I have this right.

    3DOSMODE displays the number (mine happens to be 32782) representing the binary switches that have been set for the 3D snaps in settings. It appears any odd number (1 bit turned on) turns off all 3D snaps.

    Testing shows the F4 says either Tablet On or Tablet Off. Further testing shows it doesn't seem to have any effect on 3D snaps. They occur for either On or Off and the output of the 3DOSMODE command doesn't change with an F4 press either way.

    The Clear Entity Snaps button executes the NONE command which permanently clears the 2D entity snap settings as is evidenced by OSMODE going to zero. It's not a toggle. However, if there's a command in process then it is a toggle and 2D entity snaps are restored. That button and the NONE command has no effect on 3DOSMODE.

    The Clear 3D Entity Snaps button executes the ZNONE command which permanently clears the 3D entity snap settings as is evidenced by 3DOSMODE going to zero. It is not a toggle. However, if there's a command in process then it is a toggle and 3D entity snaps are restored.

  • Testing shows the F4 says either Tablet On or Tablet Off. Further testing shows it doesn't seem to have any effect on 3D snaps. They occur for either On or Off and the output of the 3DOSMODE command doesn't change with an F4 press either way.

    In V20 the F4 function key was used to toggle the Tablet on/off. This has been modified in V21 where F4 toggles 3D entity snap.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!