CPU Usage

I'm using Linux and have a fairly complex 3D model and the CPU core usage is singular as you can see, are there any settings to enable multi threading?
Thanks in advance.


  • Yes, there are the MTFLAGS in Settings.
    I think all deactivated by default.
    I use them.

    But it depends on the Bricscad tasks. Not every task in CAD can be multi-threaded.
    So the majority of time runs single threaded anyway and likes high single core boost
    But MTFLAGS will help for thing like File loading, imports, View refresh, ....
  • Ok thanks Michael, the bottle neck I am struggling with is the VIEWBASE command and sections. Its taking ages to generate them and sometimes crashes.
    I'll have a play with MTFLAGS, cheers!
  • Hi Michael,
    Rather than create a new thread I just thought I'd ask if you or anyone else using Linux gets poor performance compared to windows. In particular when I issue a command for example Line, then click the first point, when I zoom in or out to move to the second point the screen gets very choppy, clunky & slow. This also happens with dimensions and anything else being added. In windows it is very smooth and fast.
    I've tried everything and its the only thing stopping me from using Linux as my sole OS.

    As ever any help is appreciated.

  • In the past I lost some Linux installations with one Bricscad Activation.
    My main OS is macOS and a Windows PC as a backup.
    So I rarely try Bricscad on Linux at this time, but when, without activation
    in Shape mode only.

    But I can't remember have seen any lags on Linux.

    Just the same UI or customization issues as on macOS, which aren't a thing
    in Shape only anyway.
    (My PC/Linux hardware is a 3950X with 64 GB RAM and an AMD RX6800)
  • But I can't remember have seen any lags on Linux.

    That makes me think that it could be an nvidia driver issue. I know AMD performs better with Linux, I was even considering swapping my RTX 3080 for an AMD GPU but the RTX perform really well with Blender which I use a lot, its a dilemma...
    Thanks again Michael.
  • > I know AMD performs better with Linux

    Thought that too.
    Had a RTX 2070 before.
    After installing the proprietary driver not much issues on Linux.
    (Beside when the kernel was updated before the Nvidia patch was ready)
    Switching to AMD hardware was the reason why I lost 2.5 of my 3 Linux installations :)

    Once I reinstalled, no problems with AMD GPU of course.

    But On Windows it seems I have now more problems with AMD GPU performance
    and missing CUDA etc. Got better over time but I think Nvidia is more proprietary
    but overall less problematic and more performant ....

    Anyway, I do not think it is Nvidia related.
    Maybe a regression in the current Bricscad (?) or a file problem ?

    I would file a support request in any case, they will find the reason.
  • MilesAlex
    edited July 2

    >Anyway, I do not think it is Nvidia related.
    Maybe a regression in the current Bricscad (?) or a file problem ?

    This got me thinking. I created new drawings with all the stock out of the box Bricscad .dwt files.
    The MECHANICAL and BIM .dwt files worked as they should, snappy and fast.
    All the rest SHEET, DEFAULT, SHAPE & DEFAULT where all laggy.
    So I checked the drawing explorer of each one and could see no differences other than minor things like dim style.

    As you said I think a support request is the best option. But at least for now I can use the mechanical or bim templates with good performance.

    Cheers !
  • Interesting.
    I usually use BIM only.

    But Shape templates are slow too ?
    Is there any way to control MT Flags from File Settings, to make Shape slower ?
  • Not sure, I think MT Flags are system specific.
    I also tried the above with V20 with the same results.
    How can an empty template make a difference in performance, I've even copy and pasted a large drawing into a mechanical (or bim) template with good results, any other .dwt is laggy and sluggish.
  • Sounds strange.
    Can you also see single threading only in Activity Manager
    or system Monitor.

    Or are there just some File Settings in templates that use
    higher quality display of curved lines, Antialiasing and such,
    which can slow down drawing windows ?

    I will also look into it.
  • But in general,
    For me Bricscad's 3D View Window performance is much slower
    than my primary CAD with same projects in general.

    You say you have a quite large 3D File.
    I also have often huge imports from bad RVT or IFC sources that
    make working very laggy. The large amount of objects itself slows
    down view performance, structure browser, selections, visibility
    switching, BLOCKEDIT and so on.
    Even worse if there are lots of Mesh Objects from library elements
    and if Blocks lost their instancing and come in as separate Blocks.

    When I try to AUDIT FIX it will either delete half of the geometry
    or when I try to cleanup with BIM tools it often makes Bricscad
    crash. But for me that was similar in all OSs, no matter if Windows,
    macOS or Linux.
    But can't remember having had lags when drawing a line.
  • I agree some large 3d files can get very slow to manipulate.
    I'm having lag with small 2d files and it only happens when a command is active, such as after the first point of a line or dimension has been made. Its a little hard to explain so I will create two screen capture videos with Windows and Linux.
  • I played a bit with Shape in latest Elementary OS (older kernel)
    and latest Open Suse Tumbleweed rolling release.
    (I also would like Manjaro but for me it is too tedious to install
    Bricscad's Tar Ball on it ... )

    I opened moderate 3D files (from shape templates) or Blank files
    using Shape mm template. Unfortunately I can't see any lag with
    drawing lines with my configuration..
  • I'm using Ubuntu but to rule out distro problems, I will create a new partition and try Open Suse and Fedora.
  • ElementaryOS is also mostly Ubuntu. Just their own desktop.
  • MilesAlex
    edited July 5
    Ok thanks Michael, appreciate your help. I will let you know how I get on....
  • Quick update, I tried a fresh install of Ubuntu which appears to of fixed the laggy behaviour and also I have multi-threading, Win-Win !
    Just glad its so easy to re-install Linux and get up and running quickly.
  • Do you use an external home folder ?
    (To not loose your data and settings)

    When I needed to re-install Linux I had to start from scratch again.
  • MilesAlex
    edited July 10
    Yes I did use a separate Home folder prior to getting a Synology NAS. Now I simply install the Synology Drive Client so that I can have my files Local and synced to the NAS.
    I have a folder with all the programs I want and a folder for all the CAD settings etc. Also password manager data files (keepass), email files, notebooks (synology notestation), calendars and contacts (Synology). So all my data is stored on the NAS and I also have a back-up off site. I'm big into data privacy.
    So a fresh install takes around 45mins for me, which is fully up and running with everything I need.

    I did want to try Open Suse and Fedora but the Synology software is only Ubuntu based.
    I'm actually using Linux Mint which I prefer over the Gnome desktop. I had a suspicion the lag and multi-threading problems where due to the Kernel and the newer hardware I'm using so I installed the Mint Cinnamon Edge addition which uses 5.15 kernel. Not sure if that is what fixed the issues but everything is working well up to now.


Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!