Bimify will not find structural shapes on ifc import

Does anyone else have this problem. I'm hoping its something I'm just not understanding about bimify.

We import a lot of ifc structural models. When the model comes in and we run bimify on it the structural shapes are not assigned to the appropriate profile. They are given a user designation and sizes in metric. The drawing and import are never in metric at any point.

Is there a way to get bricscad to force a harder compare at the database and get it to assign the correct structural profile instead of just a user defined section?

I have attached a screen shot of the profile and the info panel showing the results after bimify.


Comments

  • hi Fossa,
    bimify will use a profile that fits if it finds it in the library. Small differences between imported geometry and profile definition can result in a mismatch.
    However it is easy to quickly select all similar profiles in the structure browser and reassign the appropriate profile if you want to.
    You can use the attached structure configuration file to sort all entities first by profile. (copy the file in your support folder, then it is accessible in the structure browser, 3 dots, select configuration)
  • Thank you. I had no idea you could do that to that level in the structure browser. I'll give that a try.

  • I think in your case it is just the Profile missing rounding and conical parts.
    Which makes them look like custom made welded Profiles.
    (Which I would prefer overall or at least for Visualization purposes anyway)
    So it will categorize them as new Profiles.

    But meanwhile Bimify does an astonishing good job in recognizing imported
    Profiles !

    And yes, Structural Manager, with all its features, is 80% of Bricscad BIM's
    capacity alone and absolutely mandatory.
  • Definitely going to be doing some reading up on the structural browser. Thanks to Piet's post explaining that, I converted over 3000 columns, beams, and members to the correct sections in about 15 minutes.

    Thanks again to Piet.
  • I went to my settings (not migrated and from scratch this time)
    and saw that under IFC Imports, migrating Profiles was OFF by default ...

    Maybe that would have imported Profiles in the first place already (?)
  • I found that too. I was very disappointed to find it did nothing when I checked it on. Not sure why its off by default. There didn't seem to be any negligible speed reduction when I turned it on. That should always be on by default, not off. (imho)

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!