Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

9.2.7 version with lots of bugs! Don t update!

I was using version 9.1.12 and everithing ok.I updated to version 9.2.7 and i started having lots of bugs:1. erase command stops working. You need to restart the aplication.2.several fatal errors when using fillet command3.several fatal errors when using hatch commandI tried to reinstall my older version but a keep receving a message say i can t install a previous version.What can I do?


  • To reinstall an older version, the more recent version has to be uninstalled first.Concerning the problems you experience, we would strongly appreciate if you'ld post a support request and attach the drawing(s) with which you experience the mentioned problems. We will solve them with minimal delay.

  • Thanks Hans!I Have already send the crash report!Lets wait and see!

  • I have absolutely no trouble with 9.2.7. Hatching has an annoying lag, that's all.

  • In a few months this lag will become history: over the years, the hatch boundary search algorithm has proven to be one of the most difficult and complex ones throughout the Bricscad application. We are in the process of developing a brandnew boundary search algorithm, using the new geometry engine that we have been developing over the past 2 years. We have started the process of integrating our new geometry engine and replacing the old one, which will take, along with intensive testing, a few more months. Besides faster and more accurate boundary searches, this will also result in more accurate fillet and offset results.That being said (to let you know there is hope), with the drawing Ricardo provided, we have been trying to trigger crashes but did not yet succeed. Elsewhere on this forum I read that someone has the impression he no longer receives the Support Request replies we send, so just to make sure: Ricardo, could you please add a description of which erase, fillet or hatch boundary search operation, on which entities, we should try to trigger the problem?Kind regards

  • One bug I know of for 9.2.7 and 9.2.8:- start Bricscad fresh with new drawing,- draw two lines,- draw an angular dimension using these two lines,- erase the dimension,- open drawing explorer to dimension styles,- turn off the extension lines for the current dimension style.At this point Bricscad is all but dead for me.Is this repeatable for others?Greg

  • Oh, regarding the support system replies... I have reported the problem to my provider but I am willing to bet it will take a lot longer for me to get that sorted by them than the comparable service from Bricsys!You folks do good work and listen to users... Great!

  • Somehow I lost the ability to erase any of my existing viewports. If I erase a viewport somehow everything on the screen gets erased. I also am getting more fatal errors. Yes, Hans I reported this today.My suggestion is to go back to Bricscad V8. After purchasing V8 I wanted to by stock in this company. That was a very stable version. Very rarely had a fatal error. Did not know of any bugs. Every once in a while I try to upgrade to V9 but end up finding that I need to report bugs and I just wait until a newer version is released so that I can try again. The response from the support team is great but I still cannot upgrade to V9. I think we get such a good deal (price) for this product because they do not have to pay for debuggers(they have about 50,000 of them working for free).

  • Steve,thanks for providing a drawing which allowed to reproduce the problems you describe. They originate from an erronuous viewport scale calculation in case the modelspace content consists of a single horizontal line. In this case the 'view height' of the modelspace entities is 0, which is not digested well by the code that calculates the scale for a new viewport. This results in the creation of viewports with an undefined, typically huge, scale factor. These ill-defined viewports in turn trigger display problems, as you experienced, e.g. after erasing an entity, other entities are no longer displayed - the entities still exist, but their display does not succeed as long as these ill-defined viewports exist.We will fix this erronuous behaviour with priority, and add an automated test.As a temporary workaround, when creating viewports, it suffices to make sure the modelspace contains any entity that has a non-zero 'view height', e.g. a rectangle, a vertical line, a circle, a text, anything... this is probably why no one stumbled on this till now. Please note that this problem existed all along in V8 just the same, so it beats us why you insist on blaming V9.2.7. or V9 in general.

  • Maybe the problem is not fully understood yet. I have uploaded a new drawing. This drawing has a viewport with a scale 1/16"=1'-0". This viewport has an object shown with appropriate height and width. This drawing has an arrow pointing towards a viewport that you should try to erase using Bricscad V9. You will see my entire drawing disappear. Then try the same thing using Bricscad V8 and there is no problem. I have about 200 drawings in my job files that all have the same problem with V9 and not V8.

  • Thanks for the additional drawing, it indeed illustrates a regression introduced while working on improvements for the in-place mtext editor. In specific circumstances, it leads to paper space entities that are no longer displayed after erasing a viewport. It was introduced in V9.2.3, one of the beta testing builds that preceded the V9.2.7 release.We are currently working on a fix and will add additional automated tests that cover this problem. We plan to release a build containing the fix later this week.We apologize for the inconvenience caused.

  • The suport team didn't gave me any reasonable answer...It seems that the drawing doesn t crasshes with them!I detached the xref in the drawing and i didn t get any fatal error since...well...lets hope it keeps that way...Hans, do you know if 9.2.8 has improved the hatches problem?

  • Ricardo, since 4 DAYS we are asking you for a description of how to reproduce a crash, because with the drawing attached to SR 18375 our analysts keep failing to trigger a crash.Today, EXACTLY 5 MINUTES before complaining on this forum that you did not receive a reasonable answer, you have finally replied the following to our request for additional information, and added a missing xref file:[2009-01-20] [FILE UPLOADED]I think it migth be related with the xref atached.Probably you will get the same error if you atach my drawing.I have atached it in this message.Thanks guys.Well, thanks Ricardo... We will continue our investigation and try to help you out as fast as possible.

  • Greg. Yes I can reproduce this problem, now I can't even ctrl/alt/del out of it. Fortunately I never do that series of actions with dimensions.

  • Sorry, yesterday I informed Greg that we have applied a fix which will be included in the next release, but forgot to add a post here.

  • That's ok it was just a passing curiosity for me. I still have no issues with v9 (although I still liked the v8 properties interface better).Sometimes it's worthwhile comparing notes here though, before annoying Support with issues which might be local or isolated to one person's situation - if others don't have the same problem one might think twice about making a complete fool of themselves...

  • Hans,I am sorry if I took so long giving you a response.But I was a little bit confused about where to post my response.I received an e-mail from the support team and I replied that e-mail.I am afraid you guys didn t received it.I only understood that when I read your post here, saying you couldnt contact me.And, please Hans, don t get upset. I really like bricscad v9. Its a wounderfull program and I know you are doing a very good job with all the problems.And reporting problems makes the development even more solid.We are all working for the best of this great program. (clients and bricsys);)I updated to 9.2.8 and it seems the problem is not so ofen. But I keep getting a fatal error or erase stops working after 2 hours work... more less...It is dificult for me to reproduce the error because i cant find any way of doing it.Once you restart the aplication everything goes back to normal.How can I be more usefull?But I am sure you will finally get the problem solved.:)

  • Hello Hans,I have good news for you.I know how to reproduce the error and i reported it.Thanks.

  • Ricardo. I found too that some (rare?) problems might require a real effort to report, but once properly send in, support anwsers within days and a fix is applied soon after that (at least that is my experience)

  • Ricardo, your latest drawing and scenario indeed allow us to consistently reproduce the situation where entities no longer can be erased and the application becoming unstable.This is a great news, errrr, at least for the programmers who need to solve the issue... We'll work out a solution in the coming days. Thanks for helping us make Bricscad a better product.

  • Sounds like Ricardo did a great job isolating and reporting a difficult error! It sure can be a frustrating experience to try to isolate an error that is dependent on a complex sequence of events as the trigger.The real payoff to it is the fact that we know it will be fixed quickly.Hmmm... guess I better dig into my refedit problem again to see if I can get it solve as well as Ricardo found his problem!

This discussion has been closed.
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam