Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Start "Descoder myapp.prv" in Win 10 Explorer

With "FileTypesMan" from "Nirsoft" I made a fileextension and intended to compile a PRV to DES via doubleclick. Here is the command extract from FileTypeMan:

Descoder starten Descoder starten Ja Nein 01.05.2017 14:14:29 "C:\Program Files\Bricsys\BricsCAD V17 de_DE\DESCoder.exe" "%1" C:\Program Files\Bricsys\BricsCAD V17 de_DE\DESCoder.exe Nein HKEY_CLASSES_ROOT\Autolisp-Projekt\Shell\Descoder starten\Command Nein DES Encoder 2.6.0.0 DES Encoder for Standard Lisp Files TM-CAD Engineering

The problem is:
- I saw all the entries in the contextmenu and the icon is OK too, but it starts only the dialogue of descoder and does not compile the file via command-line.
- When I open CMD-dialogue and type "descoder.exe myapp.prv", it is compiled as expected.

What is missing here?

Comments

  • Hi, Peter,

    hard to tell what & why the "FileTypesMaker" associates here, to get a strange output ...
    you might scan your Registry for ".prv" manually (regedit.exe), to see the associated command string there ...

    Alternatively, you might create a small batch file (.bat or .cmd) containing that commandline, that should be fine as well
    (I also use that every day :-) )

    hope this helps a bit ...
    many greetings !

  • Hi Torsten

    this is my registry:
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.prv]
    "BrowserFlags"=dword:00000000
    "EditFlags"=dword:00000000
    "PerceivedType"="text"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.prv\DefaultIcon]
    @="C:\\Program Files\\Bricsys\\BricsCAD V17 de_DE\\DESCoder.exe,0"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.prv\Shell]
    @="Descoder starten"
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.prv\Shell\Descoder starten]
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.prv\Shell\Descoder starten\command]
    @="\"C:\\Program Files\\Bricsys\\BricsCAD V17 de_DE\\DESCoder.exe\" \"%1\""
    

    And this is my freshly created bat-file:
    "C:\Program Files\Bricsys\BricsCAD V17 de_DE\DESCoder.exe" %1

    The result is the same: It opens Descoder-dialogue which displays me the last used PRV-file, not the PRV-file I clicked on ...???

  • I think the key issue is that you are not using 'open'.
    This .reg works fine on W8.1 (use at your own risk, change the BricsCAD version to match your installation):

    Windows Registry Editor Version 5.00
    [HKEY_CLASSES_ROOT\.prv]
    @="prv_file"
    [HKEY_CLASSES_ROOT\prv_file]
    [HKEY_CLASSES_ROOT\prv_file\shell]
    [HKEY_CLASSES_ROOT\prv_file\shell\open]
    [HKEY_CLASSES_ROOT\prv_file\shell\open\command]
    @="\"C:\\Program Files\\Bricsys\\BricsCAD V16 en_US\\DESCoder.exe\" \"%1\""
  • edited May 2017

    Hi, Peter,

    as Roy mentioned (correct as usually !) - by default, double-click uses the standardised "shell/open" entries ...

    Seems, those non-standard entry is created by "FileTypesMan" ?
    maybe, the command line needs to be
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes.prv\Shell\Descoder starten\command]
    @="\"C:\Program Files\Bricsys\BricsCAD V17 de_DE\DESCoder.exe %1\""

    meaning, only 1 string, not separate strings for descoder.exe and the passed-in argument ?
    Also, as it seems to work to start descoder.exe - as you described, there is no commandline argument given to starting descoder.exe - resulting in dialog, with last-used file/project.

    So double-click should indeed work with "shell/open" entry ... those others, extras likely need more investigations, why argument is not passed as commandline argument to descoder;
    personally, I have good results with the "Send To" menu entries as well - at least, those do pass the arguments ...
    many greetings !

  • One problem (semi-)solved, next found.

    • I had my PRV-files on a network drive -> behaviour described above
    • I moved it to a local file -> it starts to work, but it does not find the lsp-source: PRV stores the path of lisp-files relatively :-(
    • I modified the path to absolute and started it from local-drive -> DES is created as desired, but now PRV and DES are on local drive where I don't want them

    I will return to the dialogue-driven compiling;I don't have that much to handle ..

This discussion has been closed.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam