Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

erase function will not erase a solid!

I've been using V16 for 2 years. My computers motherboard crashed and I bought a brand new laptop (HP Envy17.3, WIndows10) I installed both v18 and communicator on a fresh computer that I have not loaded any data files onto yet. In 3d modeling mode, I changed the screen to black, increased the size of the cross hairs and proceeded to draw a sphere using the model/3d solids/sphere command. So far so good. I hit the red "X", clicked on the sphere, hit enter, and it would not erase. It told me "only shell in body would be lost". Here's a copy of the commands

_erase
Select entities, edges or faces:
Entities in set: 1
Select entities, edges or faces:

only shell in body would be lost

Surely the erase command hasn't changed? It erases lines, circles, etc with out a problem. Has anyone ran into this?

Comments

  • I suspect you're selecting an edge or face instead of the sphere. Check SETTINGS -> SELECTIONMODES.

  • YES!!!!!!!!!!!!!! Thank you!!!! BTW, I called tech support and they forwarded my problem on to you. You can ignore that now!!!! Thank you so much!!!!!!

  • For the erase command to work properly, the SELECTIONMODES setting needs to be set to 0, or 4. In order for the QUAD cursor and 3D constraints to work properly, the setting needs to be set to 3. Is there a way to set up the erase command to automatically switch to "0" and the QUAD and 3D constraints to automatically switch to "3"?

  • Use the CTRL key to temporarily override the selection mode. If you're running with Edge, Face, and Boundary selected, for example, an unmodified select on a sphere will select the face (surface) of the sphere. As it should. Press CTRL before selecting and the solid will be selected instead.

    Similarly, with SELECTIONMODES at 0, selecting the sphere gets the solid but selecting with CTRL pressed picks up just the face.

    An automatic change of selection mode to 0 by the erase command would make it impossible, for example, to erase a fillet face or through hole.

  • Another option might be to hit the TAB key to cycle the various possible selections. E.g. if SELECTIONMODES = 3 (edges and faces) hitting the TAB key cycles between edges, faces and the entire solid. Notice that using this method obscured geometry is selectable also, which allows to select overlapping geometry in 2D drawings.

  • I'll try both ways, and report back. Thank you. BTW, what version are you guys running and what setting do you use? I ran V16 up until a few days ago, and I never had a problem...

  • edited September 16

    Thanks again, guys. It seems having the setting at 3, and just hitting the control key when erasing has it behaving as I'm accustomed. Thanks again!

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam