Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Not printing image in colour

I have an image (logo) that I open in a suitable viewer, select all, ctrl C (copy)
I then ctrl P (paste) into my drawing and suitably change the size to the correct size.
Currently on Layer 0. Colour=ByLayer. Linetype=ByLayer. Linetype scale=1.
When Brics prints this my original images print in colour but this new one is just greyscale.
Is this a setting somewhere to do with the copy/paste.

With AutoCAD this was no issue. Something screwy with BricsCAD settings .... Somewhere.

Looking forward to solving this before my AutoCAD license expires.

Thanks in advance
Kim WILLIAMS

Comments

  • Further investigation
    If I attach the image like an xref the printing is ok.
    Still not sure why the copy/paste image does not work however.
    Kim

  • Copy/pasted images should print in color. Please file a support request and include the drawing and the image. Our analysts will be glad to look into your issue.

  • I just replicated that on V20.2 beta. No need to send anything, just do screen shot with printscreen button, paste in bcad, and plot to pdf using autodesk high quality.pc3. You get greyscale.
    This is using None pen table.
    Should be easy for you to replicate too @Louis Verdonck

  • Thanks James.
    Correct ..... does not matter if you have all colour selected in the ctb or what ever.
    Still plots pdf or paper greyscale.

  • Sorry, cannot reproduce. Please notice pdf drivers have a Grey Scale option.

  • Louis
    I am printing 100% colour.
    I have a colour image that has been copy/paste into drawing using AutoCAD and this prints just fine.
    When I copy/paste a new colour image into the same drawing using BricsCAD this image does NOT print colour.
    What is attached is my drawing and at present the extra image.

    dwg
    dwg
    052-039-E-031.dwg
    315K
    Dreamworld logo.jpg
    742 x 235 - 67K
  • @Louis Verdonck
    Here is the driver being used, it does not have a greyscale option, only dpi when plotting:

    pc3.jpg
    624 x 493 - 61K
    pc3.jpg 61.4K
  • @James Maeding
    Here is the driver being used, it does not have a greyscale option, only dpi when plotting:

    This is a known issue (SR 85292). It's caused when you attempt to use a .pc3 specific to AutoCAD with BricsCAD, such as "DWG To PDF.pc3". In this situation BricsCAD still prints, but uses it's own internal defaults rather than the ones given in the PRINT dialogue.

    The work around is to avoid mixing program specific .pc3 files. In the case of "DWG To PDF.pc3" you can make a copy of BricsCAD's "Print as PDF.pc3" and rename the copy to "DWG to PDF.pc3". Print as PDF is the BricsCAD equivalent PDF printer.

    Regards,
    Jason Bourhill
    BricsCAD V20 Ultimate
    CAD Concepts

    DWG To PDF - AutoCAD.png
    624 x 493 - 108K
  • Thanks for all the prompt feedback.
    Unfortunately this did not work.
    Copied the BricsCAD 'Print as PDF.pc3' file as 'DWG to PDF.pc3'.
    Opened my image and copy/paste into my drawing.
    Bugga.... still black/white
    Not sure what else i am not getting correct..... I could generally chase down the issue in AutoCAD but this floors me.
    Regards
    Kim WILLIAMS

  • @KimbleC said:
    Thanks for all the prompt feedback.
    Unfortunately this did not work.

    My earlier post was a response to James post of his PDF printer config.

    You issue looks to be due to a bug in V20. When you PASTE an image in as an OLE it will print to pdf as greyscale. Issue doesn't affect hard copy print, or print to another PDF printer. The issue doesn't occur in V19.

    The give away is the sample drawing you provided actually already has some OLE images on them, and they print fine in V20.

    Workaround is to use BricsCAD V19 to PASTE the OLE image. After that you can switch back to BricsCAD V20.

    Recommend that you raise a support request with Bricsys to get this issue fixed.

    Regards,
    Jason Bourhill
    BricsCAD V20 Ultimate
    CAD Concepts

  • Nice catch Jason! I actually never use Ole's, I attach images...

  • Actually, it turns out that there is more to this than I originally thought. The issue sits around OLEQUALITY, its default value, how it is set, and how these settings are applied.

    In BricsCAD the default value for OLEQUALITY = 0, which means that OLE objects will be embedded to print in Monochrome. Earlier versions of BricsCAD where ignoring this value and instead applying a value from elsewhere. In V20 the setting for OLEQUALITY is respected, and because of the default value causes OLE to print in monochrome. In AutoCAD the default value is 3 meaning that the CAD application will automatically set the OLE to an appropriate print quality. There are three levels allowed:

    • 0 MONOCHROME. Monochrome (e.g. spreadsheet).
    • 1 LOW . Low graphics (e.g. color text & pie charts).
    • 2 HIGH. High graphics (e.g. photograph).

    BricsCAD however is literally applying the value for OLEQUALITY to the plot quality property of the embedded OLE, meaning it can end up set to 3 or 4, which are invalid. That you can set OLEQUALITY = 4 is also an error. The valid range is from 0 to 3.

    What does this mean?

    1. To get OLE to print in colour you need to set OLEQUALITY = 1, or 2. Ideally you would set to 3 (Automatic), but currently this will result in the OLE getting set to an invalid value.
    2. The OLEQUALITY setting is applied to the OLE object on embedding. Currently to change, you need to re-embed the OLE. I don't see any command based options to adjust.

    Luckily you can use some LISP to change the OLE plot quality of existing OLE entities. The attached LISP will allow you to do this.

    Regards,
    Jason Bourhill
    BricsCAD V20 Ultimate
    CAD Concepts

    lsp
    lsp
    SetOlePlotQuality.lsp
    3K
  • Thanks Jason .... Not sure if I am able to download and use V19 as I have already registered V20.
    James ..... If the image is OLEs then the issue of sending the native drawing is that you must also send the image. These are generally only logos in the drawings anyway.

    I have raised a support ticket - SR100004.
    Will try and keep the forum posted hopefully with suitable resolution.

    Regards
    Kim WILLIAMS

  • @KimbleC said:
    Not sure if I am able to download and use V19 as I have already registered V20.

    BricsCAD licenses are backwards compatible. If you have a V20 license, then you have the option of running any version of BricsCAD as far back as V14.

    Per my previous post, it turns out it isn't necessary to install V19. You just have to set OLEQUALITY = 1 or 2 prior to embedding an image.

    For existing OLE objects you can use the LISP routine I included to change the OLE plot quality to one that supports colour.

    Regards,
    Jason Bourhill
    BricsCAD V20 Ultimate
    CAD Concepts

  • As promised I have had a suitable answer from Support.

    Tiberiu Toader 10-03-2020 09:11 UTC
    Dear Kim,
    OLE image visibility display is controlled by _OLEQUALITY variable, by default is set to [0] Monochrome. The ole2frame has a dxf73 storing the OLEQUALITY used at insert time. This field will not change if you change OLEQUALITY afterwards.

    Go to Settings > Program Options > OLE and metafiles > OLE quality > Change the variable from the dropdown menu. By doing this before the insertion of the OLE, the problem is solved. Please check the attached video.

    Best regards,
    Tiberiu
    The Bricsys Team

    Also thanks to Jason Bourhill

    You just have to set OLEQUALITY = 1 or 2 prior to embedding an image.

    Thanks to all

    Regards
    Kim WILLIAMS

Sign In or Register to comment.
Origami
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam