Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Working with tables, how to force a comma to show up for numbers

Coming from AutoCAD I could create a table in a drawing and input numbers into it. If the number was anything greater than 999 then AutoCAD would automatically add the necessary comma at the thousands or millions place. I have searched high and low in all of the help forums and cannot figure out how to force this behavior in table in BricsCad


  • This is a Autocad solution not sure how in BRICSCAD I am sure can get at it program wise just need to find the correct variable in Table definition

    1094 x 706 - 92K
  • I had a deeper look and found this but there must be though a over riding top level setting. It will be part of the table dictionary, I just looked at a table. It is feasible to update all the cells via a lisp.

    (vla-getcellformat Obj 2 0)
    "%lu2%th44" is the thousands format for a cell

    Command: (vla-getText Obj 2 2)

Sign In or Register to comment.
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam