Express Tools for V15

 Hi there,
I have two questions:
  1. I thought I read somewhere that some of Express Tools are now built into V15. True or False?
  2. I see there is a version of Express Tools for V15 but I cannot download it from either the Bricsys site or from
    Anyone else have this problem. Does anyone have the Tools that could email them to me?
Thank you in advance for your help.


  •  2. Express Tool's Bricscad Applications DL link doesn't seem to be working here either, but it works fine at the Cadwiesel website.
    Also, BcadTools DL works fine in Bricscad Applications, as well as website.
  • Hi there,
    I am still having a problem, now I can download the file but it won't open.

    WinZip reports the following error: "Error: Central Directory Not Found"

    Still hoping to be able to install these tools.
  • Hi,

    I'm also having problems. Downloads fine, but Windows cannot seem to open open the zip file.

    Would be nice to have :)


    imageexpress tools2.PNG
  •  I can confirm issues when trying to extract in Windows.
    Extracting using 7-zip, however, works properly.
  • Still needs tweaks for Bricscad 15.

    for instance:

    Layman is just layer in V15

  • Extracted with 7 zip now, works fine.

  • Thanks all :)


  •  I agree with Stefaan Coddé,
    V15 of Express tools seems to needs tweaks.
    I'm sorry to say that because we rely on these tools, moving our computers to V15 of Bricscad is going to be hindered.
    Sorry Bricsys :(
  • Which of the Express Tools are you having trouble with?  There may be other lisp routines that will do the same things or there may be re-writes that were done before the package from cadwiesel was released.
  •  I finally installed v15 for evaluation.
    Also installed latest Express Tools, as well as BCAD tools.
    Both appear to function as they did in v14 before.
  • I would like to know how to install Express Tools :)


  • You can find Bcad tools and Express tools, along with other free stuff, on the 'Free Tools & Add-ons' page of the Applications Catalogue

  •  Oops, I accidently replaced Ami's last response with my reply. Sorry for that Ami.
  • No problem



  • Extracting the files using the 7zip program was the least of my concerns. It was a bit inconvenient but I got it done.

    However, I was a little sceptical when the file to load is (load "Acettest.des") instead of (load "Acetutil.des"). The word "test" indicates to me the program is probably not ready for prime time. Then as I played around with the program...
    • Some of the routines fail to execute
      Unable to recognize command "CURLAY"
      error : no function definition
      (- TPOS 1) ;* too few / too many arguments at [ACET-UI-GETFILE]
      (and numerous others)
    • Some of the dialogue buttons and boxes are still in German and not English
    • When I uninstalled the Express menu and restarted BricsCAD it would load the toolbars but not the Express menu. I had to go search for the CUI file in the support path and reload that to bring back the menu bar list of Express tools.
    I wish there were a way to get this de-bugged and running again. They are a great set of tools.
  • @ Phillip: Have you tried to get in touch with Martin Drese (a.k.a. Cadwiesel)?
  • @Phillip Rutledge:
    ...unable to recognize command "CURLAY"...

    This was also the case with v14 Express Tools.
    An easy fix is to Customize the Menu Item, changing the Command from:
    ^C^CCurlay To:

    I'm sorry, I cannot comment on your other issues.
  • Try LAYCUR

    Did anyone ever get Express Tools to download to BricsCad Classic?

  • Getting Express Tools to download to BricsCad Classic has been such a headache. I still can not get it to work.

  • <



    blockquote class="Quote UserQuote">

    Getting Express Tools to download to BricsCad Classic has been such a headache. I still can not get it to work.

    I did notice that it is missing these file extentions, which is needed to create a menu.






  • now i'm back in the real World and try to help.
    We changed the Server and it seems the downloadpackage was broken, while moving from the old to the new server. Now i upd a new Package. I hope the faults are over now.
    Please report if something won't work.


  •  Sorry Martin, still doesn't open in windows explorer or winzip. I was able to download it from your website and using 7-zip I was able to extract the files but the end result seemed to be a mix of German and English and some commands/routines didn't work.
  •  And how about this error, after installing Express? 

    : RTEXT

    BKG_Rtext - Program version 20141107 
    Copyright (c) 2011-2014 Roy Klein Gebbinck - All rights reserved 
    Use:  BKG_Rtext  BKG_RtextEdit  BKG_RtextUpdate 
    Or:   BRT        BRTE           BRTU 
    Current settings: Style=_A2P Texto  Height=0.25000000  Rotation=0
    Enter an option [Style/Height/Rotation/File/Diesel] : D
    ; ----- LISP : Call Stack -----
    ; [0]...C:RTEXT
    ; [1].....FETCH
    ; [2].......ACETRTEXT:PICKTEXT <<-- </div>
    ; ----- Error around expression -----
    (ACET-UI-TXTED STR "Edit RText")
    ;* no function definition ; expected FUNCTION at [eval]

    Please help. What's hapenning??
  • @ Luis:
    It seems that Martin has wrapped my functions and something is going wrong.
    Try using one of the three original commands: BKG_Rtext, BKG_RtextEdit or BKG_RtextUpdate.
  • Dear Luis, Dear Roy,
    it seems, something got broken when we moved the ExpressTools API (all the acet-xxx functions) directly to Lisp engine core ...
    I will check + fix the problem, Martin has provided his sources for ExpressTools commands to me.
    So it should be easy to compare + fix.
    Many greetings !
  •  Great,

    Thank you all. :)

    Can you please let me know when you get it? 

    My e-mail is:

  • There is a minor issue in ExpressTools by Martin Drese (CadWiesel) …
    this problem with RText only happens very rare - when it is just the first command used from ExpressTools :-)

    I notified Martin Drese about, and it is indeed very simple to fix (I tried on my machine).

    Here is a simple workaround :
    to have RText working, you only need to pre-load "Acetutil.des" from ./Express folder, for each drawing …

    The easiest way is to to add a "on_doc_load.lsp" to ./Express folder, with this content
    (load "Acetutil.des")

    If you already have such an "on_doc_load.lsp" on another folder, you can also add that statement therel.

    Many greetings !

  • Also have error in Bricscad v15 (x64):

    : TCOUNT
    Укажите объекты для добавления в набор:
    Укажите объекты для добавления в набор:
    Противоположный угол:
    Укажите объекты для добавления в набор:
    Sort selected objects by [X/Y/Wahlreihenfolge] : y
    Specify starting number and increment (Start,increment) <1,1>:
    Placement of numbers in text [Overwrite/Prefix/Suffix/Find&replace..] : o

    ; ----- LISP : Call Stack -----
    ; [0]...C:TCOUNT
    ; [1].....ACET-TCOUNT
    ; [2].......ACET-ESORT
    ; [3].........ACET-LIST-ISORT
    ; [4]...........ACET:ISORT <<--<br>;
    ; ----- Error around expression -----
    ;* no function definition ; expected FUNCTION at [eval]

  • Dear Sergey,

    do you really use ExpressTools for BricsCAD V15 ?

    This is the implementation used by ET V15
    (defun acet-list-isort (plst index) (isort plst index))

    It uses "isort" fucntion, not ACET:ISORT ... please check which version of ET you use;
    ExpressTools is specific for each BricsCAD version.

    Many greetings !
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!