Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Cannot access any components from component library

When i go to components, I only see an icon for all. When i click on it no components are available. Why is this? I was looking for windows and bolts.


  • Maybe you have the wrong Path(s) for Components assigned in your Settings.

    Which could happen when you choose to migrate older Settings when
    installing a newer Bricscad Version.

  • edited December 2019

    This is a fresh install. I followed this link and I was unable to see any folders for components.

  • I had to manually set the path for me on some OS too,
    I thought it might be related to my migration of older Settings.

    Do you use Mac or Linux Version ?
    Not sure if it was all ok on Windows but it is very likely there
    as this is the best supported version.

  • @Michael Mayer said:
    I had to manually set the path for me on some OS too,
    I thought it might be related to my migration of older Settings.

    Do you use Mac or Linux Version ?
    Not sure if it was all ok on Windows but it is very likely there
    as this is the best supported version.

    Windows 10 version, apparently my vendor said it is a bug and they are not available in V20, do you have access to them in this version?

  • Yes, I have V20 Windows.

    And I remember that I had also no Components and needed to add the
    Components Path to something..../ en_US/Vxx/Support/.... manually.

    I just don't remember on which OS or which Version where it was necessary.
    And so far I just thought it would be my fault.

  • Tried that using support folder command but nothing there for component files
  • BTW, I use Bricscad BIM.

    I think I have them here :
    and some here :
    C:\Users\Name\AppData\Roaming\Bricsys\BricsCAD\V20x64\en_US\Support\DesignLibrary\Standard Parts

  • yes i have that same folder structure but i have no folder for components and no folder for standard parts. Actually Im thinking its a deliberate limitation of being on a trial, otherwise anyone could sign up for a trial and just reuse those components so makes sense, no problem I am going to buy a license soon. I did want to see the quality of components available, is it good? Is there a library of bolts/screws/holes for instance?


  • The arrangement has changed from V19 to V20. Previously answered here

    Jason Bourhill
    BricsCAD V20 Ultimate
    CAD Concepts

  • When I delete the V20x64 folder in C:\Users\\AppData\Roaming\Bricsys\Bricscad, then restart BricsCAD the folder is restored as a copy of the C:\Program Files\Bricsys\BricsCAD V20 en_US\UserDataCache folder. So, when the folder is missing for some reason restarting BricsCAD solves the problem.

  • That’s not the issue. It’s not a thumbnail issue.

    I dont have any files or folders that should be there.

    I have not used bricsys before and this is a clean install that I have been using for three weeks now
  • In V20 the library files are no longer stored under the roaming profile folder. This previous post
    Details where they are now located and how to enable from the Components Panel.

    I should also mention that the Components Panel will only display if you have the appropriate license level. I believe this is BricsCAD Platinum and above.

    Jason Bourhill
    BricsCAD V20 Ultimate
    CAD Concepts

  • I belive I had a similar issue a few weeks back, and could only see one components icon and no components in BricsCAD BIM. I reinstalled V20 several times and also tried many other things before I finally got it resolved.

    First I uninstalled V20, and then deleted the Bricsys program folder. From there, I made hidden items visible. Then I found a folder called ProgramData that has a Bricsys folder. This was deleted as well and I ran my registry cleaner several times to make sure that all traces of BricsCAD were removed.

    When I reinstalled V20 after this process, the folders and components where there in BricsCAD BIM. Only problem then was that I had double sets of Components People in Shape. This got resolved by a suggestion from Bricsys Support - deleting C:\Users\\AppData\Roaming\Bricsys\BricsCAD Shape\V20x64

    451 x 88 - 6K
  • Hi,

    As Jason explained excellently in the posts above the components are no longer copied through to the support location but they're read directly from the installation folder. For user created components multiple libraries can be added in componentspath. Unfortunately in the first release of the V20 there was a bug where in some installations the Bricsys libraries were not found. This bug has been solved since the 20.1.06 release. So in case you still run into this in the latest update please create an issue so our support team can help solve this problem:


  • null
    Yes I looked at this. uninstalling and reinstalling and deleting folders is not a great solution but seems to be only way to get access to the standard bim and mech components
  • I can confirm that after installing the new v20 release of bricsys I am seeing all the standard components now
Sign In or Register to comment.
Origami is the Japanese word for paper folding. ORI means to fold and KAMI means paper and involves the creation of paper forms usually entirely by folding.

Powered by VanillaForums, Designed by Steam